summaryrefslogtreecommitdiff
path: root/dev-db/sqliteman/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-db/sqliteman/files
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-db/sqliteman/files')
-rw-r--r--dev-db/sqliteman/files/sqliteman-1.2.2-lpthread.patch19
-rw-r--r--dev-db/sqliteman/files/sqliteman-1.2.2-qscintilla-2.10.patch13
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-db/sqliteman/files/sqliteman-1.2.2-lpthread.patch b/dev-db/sqliteman/files/sqliteman-1.2.2-lpthread.patch
new file mode 100644
index 000000000000..a9bf4f4f9528
--- /dev/null
+++ b/dev-db/sqliteman/files/sqliteman-1.2.2-lpthread.patch
@@ -0,0 +1,19 @@
+Resolves underlinking issue causing build failure on uclibc.
+
+Author: René Rhéaume <rene.rheaume@gmail.com>
+Gentoo-bug: 587076
+
+--- a/sqliteman/CMakeLists.txt
++++ b/sqliteman/CMakeLists.txt
+@@ -183,7 +183,10 @@ IF (WIN32)
+ # don't use console subsystem
+ IF (MINGW)
+ TARGET_LINK_LIBRARIES(${EXE_NAME} "-mwindows")
+- ENDIF (MINGW)
++ ENDIF (MINGW)
++ELSE (WIN32)
++ FIND_PACKAGE(Threads)
++ TARGET_LINK_LIBRARIES(${EXE_NAME} ${CMAKE_THREAD_LIBS_INIT})
+ ENDIF (WIN32)
+
+
diff --git a/dev-db/sqliteman/files/sqliteman-1.2.2-qscintilla-2.10.patch b/dev-db/sqliteman/files/sqliteman-1.2.2-qscintilla-2.10.patch
new file mode 100644
index 000000000000..c197ad342111
--- /dev/null
+++ b/dev-db/sqliteman/files/sqliteman-1.2.2-qscintilla-2.10.patch
@@ -0,0 +1,13 @@
+diff --git a/cmake/modules/FindQScintilla.cmake b/cmake/modules/FindQScintilla.cmake
+index c4592d0..7700ec4 100644
+--- a/cmake/modules/FindQScintilla.cmake
++++ b/cmake/modules/FindQScintilla.cmake
+@@ -21,7 +21,7 @@ IF(QT4_FOUND)
+ "${QT_INCLUDE_DIR}/Qsci" /usr/include /usr/include/Qsci
+ )
+
+- SET(QSCINTILLA_NAMES ${QSCINTILLA_NAMES} qscintilla2 libqscintilla2)
++ SET(QSCINTILLA_NAMES ${QSCINTILLA_NAMES} qscintilla2 libqscintilla2 qscintilla2_qt4 libqscintilla2_qt4)
+ FIND_LIBRARY(QSCINTILLA_LIBRARY
+ NAMES ${QSCINTILLA_NAMES}
+ PATHS ${QT_LIBRARY_DIR}