summaryrefslogtreecommitdiff
path: root/dev-db/spatialite/spatialite-5.0.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-12 16:41:52 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-12 16:41:52 +0100
commitd4de2b287be5b8553180509934fd44ef3d7fce3c (patch)
treea12a5c99efcbae7b7d052e2f8ad1adf8caf638e1 /dev-db/spatialite/spatialite-5.0.1-r2.ebuild
parentfc1125ea4b3373e327ba0e157daa1d7e8aee15f9 (diff)
gentoo auto-resync : 12:09:2023 - 16:41:52
Diffstat (limited to 'dev-db/spatialite/spatialite-5.0.1-r2.ebuild')
-rw-r--r--dev-db/spatialite/spatialite-5.0.1-r2.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-db/spatialite/spatialite-5.0.1-r2.ebuild b/dev-db/spatialite/spatialite-5.0.1-r2.ebuild
new file mode 100644
index 000000000000..9e9e02eba1df
--- /dev/null
+++ b/dev-db/spatialite/spatialite-5.0.1-r2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="lib${PN}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A complete Spatial DBMS in a nutshell built upon sqlite"
+HOMEPAGE="https://www.gaia-gis.it/gaia-sins/"
+SRC_URI="https://www.gaia-gis.it/gaia-sins/${MY_PN}-sources/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MPL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+geos iconv +proj rttopo test +xls +xml"
+# Further poking required
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-db/sqlite-3.7.5:3[extensions(+)]
+ sys-libs/zlib[minizip]
+ geos? ( >=sci-libs/geos-3.4 )
+ proj? ( sci-libs/proj:= )
+ xls? ( dev-libs/freexl )
+ xml? ( dev-libs/libxml2 )
+ rttopo? ( sci-geosciences/librttopo )
+"
+DEPEND="${RDEPEND}"
+
+REQUIRED_USE="test? ( iconv )"
+
+src_configure() {
+ # 1) gcp disabled for now to preserve MPL licence
+ econf \
+ --disable-gcp \
+ --disable-examples \
+ --disable-static \
+ --enable-epsg \
+ --enable-geocallbacks \
+ $(use_enable rttopo) \
+ $(use_enable geos) \
+ $(use_enable geos geosadvanced) \
+ $(use_enable iconv) \
+ $(use_enable proj) \
+ $(use_enable xls freexl) \
+ $(use_enable xml libxml2)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}