summaryrefslogtreecommitdiff
path: root/dev-db/sadisplay
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-db/sadisplay
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-db/sadisplay')
-rw-r--r--dev-db/sadisplay/Manifest3
-rw-r--r--dev-db/sadisplay/metadata.xml21
-rw-r--r--dev-db/sadisplay/sadisplay-0.4.8.ebuild29
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-db/sadisplay/Manifest b/dev-db/sadisplay/Manifest
new file mode 100644
index 000000000000..5398f713845d
--- /dev/null
+++ b/dev-db/sadisplay/Manifest
@@ -0,0 +1,3 @@
+DIST sadisplay-0.4.8.tar.gz 9063 BLAKE2B a6b965d6703102000510ae6100a6bb4d0ad5b42543408aea520476128897bf8f38fda276ea39ac066e9b6621ecf2634d20e82ca21543b8c0bb472ac5d804b2a1 SHA512 c3707f90a20028fdb164caa3037f4ffff3da3f4bc763c400f8204dae4d7d71862e65902892d8ad0fe3bbe636cf87e4f96a475e01e8ce0ac55bed4e17073e3308
+EBUILD sadisplay-0.4.8.ebuild 664 BLAKE2B b4484af68f6bee2a285a52aff2288ec2fc16bacec5f9731c538bb0a49205791c4f6a3633dd48f8c654a30fb73a1b5a1b7bee620edca87dc573b4afbd891e388e SHA512 ce7377769fa177cec3e959845c584b264efe54a4933eac04874dd04c53a6b6edd61bf97fae4e7c66f9ea879f91d55b6ac6f4e480c1c136a1a24fd89399d9248e
+MISC metadata.xml 731 BLAKE2B f661d037e9ab428af2c3033ccd1ea68578e66200ceb5cda2318b23c87b1a98fa36ccc4941c38ccfeaf4718395df81f1fc3dc6eb793068372f7ced968954b9b2b SHA512 c05e53460ae66a3c52b3a17ec0547962338bd7beb07b9d8f79d43184ff8fd433eb8eaf4bafbb288555016b33f6b296715fcaf2eb73f571dfffdc593773ffbf74
diff --git a/dev-db/sadisplay/metadata.xml b/dev-db/sadisplay/metadata.xml
new file mode 100644
index 000000000000..5e098e138e88
--- /dev/null
+++ b/dev-db/sadisplay/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>horea.christ@gmail.com</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ Simple package for describing SQLAlchemy schema and display raw
+ database tables by reflecting feature. Works with mapped classes
+ and raw tables. Relation detecting by ForeignKey columns.
+ Supports mapped class inherit.
+ </longdescription>
+ <upstream>
+ <remote-id type="bitbucket">estin/sadisplay</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-db/sadisplay/sadisplay-0.4.8.ebuild b/dev-db/sadisplay/sadisplay-0.4.8.ebuild
new file mode 100644
index 000000000000..04ab38a361c6
--- /dev/null
+++ b/dev-db/sadisplay/sadisplay-0.4.8.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="SqlAlchemy schema display script"
+HOMEPAGE="https://bitbucket.org/estin/sadisplay/wiki/Home"
+COMMIT_ID="d67d12894ebd"
+SRC_URI="https://bitbucket.org/estin/sadisplay/get/${COMMIT_ID}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/sqlalchemy[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )
+ "
+S="${WORKDIR}/estin-${PN}-${COMMIT_ID}"
+
+python_test() {
+ nosetests -v || die
+}