summaryrefslogtreecommitdiff
path: root/dev-db/sadisplay
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-db/sadisplay
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-db/sadisplay')
-rw-r--r--dev-db/sadisplay/Manifest3
-rw-r--r--dev-db/sadisplay/metadata.xml21
-rw-r--r--dev-db/sadisplay/sadisplay-0.4.8.ebuild29
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-db/sadisplay/Manifest b/dev-db/sadisplay/Manifest
new file mode 100644
index 000000000000..12aed1292b6b
--- /dev/null
+++ b/dev-db/sadisplay/Manifest
@@ -0,0 +1,3 @@
+DIST sadisplay-0.4.8.tar.gz 9063 SHA256 30d786c33c62ca91b65d6e70753455d0a57fe67737856fa0f00f7ddb9789c9e5 SHA512 c3707f90a20028fdb164caa3037f4ffff3da3f4bc763c400f8204dae4d7d71862e65902892d8ad0fe3bbe636cf87e4f96a475e01e8ce0ac55bed4e17073e3308 WHIRLPOOL 18c5d8b180c8390eb8d0d320b5889e5c8daa6b1191ccb017d7d1845c2c41d5d939a98c8a7d70d84d2de217f296e20830653c836a022ec668ed0042673d3af263
+EBUILD sadisplay-0.4.8.ebuild 664 SHA256 b17ad6a53e08b4896ee1d65e80ffff40a3e74a6f582a15f8b561725d46d5aec9 SHA512 ce7377769fa177cec3e959845c584b264efe54a4933eac04874dd04c53a6b6edd61bf97fae4e7c66f9ea879f91d55b6ac6f4e480c1c136a1a24fd89399d9248e WHIRLPOOL 8564b661b3f243af8521201c398a4d1963a602e4c0d01af2390571a24f33ef63a1d1bc7c77f884689159da9993714bc85f5a6c74e9fc3c6bac4349ed4b781765
+MISC metadata.xml 731 SHA256 c65cff016de5a8c7feac99affa3071988cc1996b64784532aa7fad3ecf823fa2 SHA512 c05e53460ae66a3c52b3a17ec0547962338bd7beb07b9d8f79d43184ff8fd433eb8eaf4bafbb288555016b33f6b296715fcaf2eb73f571dfffdc593773ffbf74 WHIRLPOOL 995561986ad633be9583d7702ec2331a22009de84bc49da15cab772d8f4bc1d62fd9cee5c57f37b4d0e1c074c18f829d32dc09aee4b13e1278fc1c0182cb983c
diff --git a/dev-db/sadisplay/metadata.xml b/dev-db/sadisplay/metadata.xml
new file mode 100644
index 000000000000..5e098e138e88
--- /dev/null
+++ b/dev-db/sadisplay/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>horea.christ@gmail.com</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ Simple package for describing SQLAlchemy schema and display raw
+ database tables by reflecting feature. Works with mapped classes
+ and raw tables. Relation detecting by ForeignKey columns.
+ Supports mapped class inherit.
+ </longdescription>
+ <upstream>
+ <remote-id type="bitbucket">estin/sadisplay</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-db/sadisplay/sadisplay-0.4.8.ebuild b/dev-db/sadisplay/sadisplay-0.4.8.ebuild
new file mode 100644
index 000000000000..04ab38a361c6
--- /dev/null
+++ b/dev-db/sadisplay/sadisplay-0.4.8.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="SqlAlchemy schema display script"
+HOMEPAGE="https://bitbucket.org/estin/sadisplay/wiki/Home"
+COMMIT_ID="d67d12894ebd"
+SRC_URI="https://bitbucket.org/estin/sadisplay/get/${COMMIT_ID}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/sqlalchemy[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )
+ "
+S="${WORKDIR}/estin-${PN}-${COMMIT_ID}"
+
+python_test() {
+ nosetests -v || die
+}