summaryrefslogtreecommitdiff
path: root/dev-db/rqlite/rqlite-7.17.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-11 11:46:23 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-11 11:46:23 +0100
commit2046683958d0497bec1458741dc867558b69e622 (patch)
tree7e3b4eb74040f3fb955d11fe2db0ef9da77af912 /dev-db/rqlite/rqlite-7.17.0.ebuild
parent980af9d76d4b7d7541b41eeff427e5cbd5cf7ec3 (diff)
gentoo auto-resync : 11:05:2023 - 11:46:23
Diffstat (limited to 'dev-db/rqlite/rqlite-7.17.0.ebuild')
-rw-r--r--dev-db/rqlite/rqlite-7.17.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-db/rqlite/rqlite-7.17.0.ebuild b/dev-db/rqlite/rqlite-7.17.0.ebuild
new file mode 100644
index 000000000000..7e1f211104cf
--- /dev/null
+++ b/dev-db/rqlite/rqlite-7.17.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+EGIT_COMMIT=6d22e2be6bc7b40571bd8ecf8366986da2f7198c
+
+DESCRIPTION="Replicated SQLite using the Raft consensus protocol"
+HOMEPAGE="https://github.com/rqlite/rqlite https://www.philipotoole.com/tag/rqlite/"
+SRC_URI="https://github.com/zmedico/rqlite/archive/v${PV}-vendor.tar.gz -> ${P}-vendor.tar.gz"
+
+LICENSE="MIT Apache-2.0 BSD CC0-1.0 MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S=${WORKDIR}/${P}-vendor
+
+src_compile() {
+ GOBIN="${S}/bin" \
+ go install \
+ -ldflags="-X main.version=v${PV}
+ -X main.branch=master
+ -X main.commit=${EGIT_COMMIT}
+ -X main.buildtime=$(date +%Y-%m-%dT%T%z)" \
+ ./cmd/... || die
+}
+
+src_test() {
+ GOBIN="${S}/bin" \
+ go test ./... || die
+}
+
+src_install() {
+ dobin bin/*
+ dodoc -r *.md DOC
+}