summaryrefslogtreecommitdiff
path: root/dev-db/redis/redis-7.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-db/redis/redis-7.0.0.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-db/redis/redis-7.0.0.ebuild')
-rw-r--r--dev-db/redis/redis-7.0.0.ebuild38
1 files changed, 24 insertions, 14 deletions
diff --git a/dev-db/redis/redis-7.0.0.ebuild b/dev-db/redis/redis-7.0.0.ebuild
index daabb56d3c64..617c6726205d 100644
--- a/dev-db/redis/redis-7.0.0.ebuild
+++ b/dev-db/redis/redis-7.0.0.ebuild
@@ -14,7 +14,7 @@ LUA_COMPAT=( lua5-1 luajit )
# Upstream have deviated too far from vanilla Lua, adding their own APIs
# like lua_enablereadonlytable, but we still need the eclass and such
# for bug #841422.
-inherit autotools flag-o-matic systemd toolchain-funcs lua-single tmpfiles
+inherit autotools edo flag-o-matic lua-single multiprocessing systemd tmpfiles toolchain-funcs
DESCRIPTION="A persistent caching system, key-value, and data structures database"
HOMEPAGE="https://redis.io"
@@ -22,8 +22,8 @@ SRC_URI="https://download.redis.io/releases/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE="+jemalloc ssl systemd tcmalloc test"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="+jemalloc selinux ssl systemd tcmalloc test"
RESTRICT="!test? ( test )"
COMMON_DEPEND="
@@ -38,6 +38,7 @@ RDEPEND="
${COMMON_DEPEND}
acct-group/redis
acct-user/redis
+ selinux? ( sec-policy/selinux-redis )
"
BDEPEND="
@@ -66,9 +67,6 @@ PATCHES=(
src_prepare() {
default
- # unstable on jemalloc
- > tests/unit/memefficiency.tcl || die
-
# Copy lua modules into build dir
#cp "${S}"/deps/lua/src/{fpconv,lua_bit,lua_cjson,lua_cmsgpack,lua_struct,strbuf}.c "${S}"/src || die
#cp "${S}"/deps/lua/src/{fpconv,strbuf}.h "${S}"/src || die
@@ -134,18 +132,30 @@ src_compile() {
}
src_test() {
- # Known to fail with FEATURES=usersandbox
- if has usersandbox ${FEATURES}; then
- ewarn "You are emerging ${P} with 'usersandbox' enabled." \
- "Expect some test failures or emerge with 'FEATURES=-usersandbox'!"
+ local runtestargs=(
+ --clients "$(makeopts_jobs)" # see bug #649868
+ )
+
+ if has usersandbox ${FEATURES} || ! has userpriv ${FEATURES}; then
+ ewarn "oom-score-adj related tests will be skipped." \
+ "They are known to fail with FEATURES usersandbox or -userpriv. See bug #756382."
+
+ runtestargs+=(
+ # unit/oom-score-adj was introduced in version 6.2.0
+ --skipunit unit/oom-score-adj # see bug #756382
+
+ # Following test was added in version 7.0.0 to unit/introspection.
+ # It also tries to adjust OOM score.
+ --skiptest "CONFIG SET rollback on apply error"
+ )
fi
if use ssl; then
- ./utils/gen-test-certs.sh
- ./runtest --tls
- else
- ./runtest
+ edo ./utils/gen-test-certs.sh
+ runtestargs+=( --tls )
fi
+
+ edo ./runtest "${runtestargs[@]}"
}
src_install() {