summaryrefslogtreecommitdiff
path: root/dev-db/redis/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-17 09:31:54 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-17 09:31:54 +0100
commit5a21cec0c36dba03507dcbd5e8ab6698d00b39bf (patch)
treeaa76c2f85f9c77c2f9a5af47ae0aa6509585770a /dev-db/redis/files
parent280d9db9f9470686aae5ce1fa4cfa57b26e9beb2 (diff)
gentoo auto-resync : 17:08:2023 - 09:31:54
Diffstat (limited to 'dev-db/redis/files')
-rw-r--r--dev-db/redis/files/redis-7.2.0-system-jemalloc.patch33
-rw-r--r--dev-db/redis/files/redis-sentinel-7.2.0-config.patch27
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-db/redis/files/redis-7.2.0-system-jemalloc.patch b/dev-db/redis/files/redis-7.2.0-system-jemalloc.patch
new file mode 100644
index 000000000000..cc2c51a50ea9
--- /dev/null
+++ b/dev-db/redis/files/redis-7.2.0-system-jemalloc.patch
@@ -0,0 +1,33 @@
+Rebased from original redis-5.0-shared.patch
+
+diff --git a/src/Makefile b/src/Makefile
+index ecbd2753d..275446338 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -65,10 +65,7 @@ PYTHON := $(shell which python3 || which python)
+ endif
+
+ # Default allocator defaults to Jemalloc on Linux and libc otherwise
+-MALLOC=libc
+-ifeq ($(uname_S),Linux)
+- MALLOC=jemalloc
+-endif
++MALLOC?=jemalloc
+
+ # To get ARM stack traces if Redis crashes we need a special C flag.
+ ifneq (,$(filter aarch64 armv%,$(uname_M)))
+@@ -266,9 +263,8 @@ ifeq ($(MALLOC),tcmalloc_minimal)
+ endif
+
+ ifeq ($(MALLOC),jemalloc)
+- DEPENDENCY_TARGETS+= jemalloc
+- FINAL_CFLAGS+= -DUSE_JEMALLOC -I../deps/jemalloc/include
+- FINAL_LIBS := ../deps/jemalloc/lib/libjemalloc.a $(FINAL_LIBS)
++ FINAL_CFLAGS+= -DUSE_JEMALLOC -DJEMALLOC_NO_DEMANGLE
++ FINAL_LIBS+= -ljemalloc -ldl
+ endif
+
+ # LIBSSL & LIBCRYPTO
+--
+2.41.0
+
diff --git a/dev-db/redis/files/redis-sentinel-7.2.0-config.patch b/dev-db/redis/files/redis-sentinel-7.2.0-config.patch
new file mode 100644
index 000000000000..db9df6786c19
--- /dev/null
+++ b/dev-db/redis/files/redis-sentinel-7.2.0-config.patch
@@ -0,0 +1,27 @@
+Rebased from original redis-sentinel-5.0-config.patch
+
+diff --git a/sentinel.conf b/sentinel.conf
+index b7b3604f0..a1d7bfea9 100644
+--- a/sentinel.conf
++++ b/sentinel.conf
+@@ -17,7 +17,7 @@ daemonize no
+ # When running daemonized, Redis Sentinel writes a pid file in
+ # /var/run/redis-sentinel.pid by default. You can specify a custom pid file
+ # location here.
+-pidfile /var/run/redis-sentinel.pid
++pidfile /run/redis-sentinel.pid
+
+ # Specify the server verbosity level.
+ # This can be one of:
+@@ -31,7 +31,7 @@ loglevel notice
+ # Specify the log file name. Also the empty string can be used to force
+ # Sentinel to log on the standard output. Note that if you use standard
+ # output for logging but daemonize, logs will be sent to /dev/null
+-logfile ""
++logfile "/var/log/redis/sentinel.log"
+
+ # To enable logging to the system logger, just set 'syslog-enabled' to yes,
+ # and optionally update the other syslog parameters to suit your needs.
+--
+2.41.0
+