summaryrefslogtreecommitdiff
path: root/dev-db/qt5-sqlcipher/qt5-sqlcipher-0.1.1_pre20171123.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-01 03:04:39 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-01 03:04:39 +0000
commit407525b571b48cfd65e1ad7a02d250a927c967c9 (patch)
tree844bea44d85dc7218f54970af1c42cc9d55c3f1a /dev-db/qt5-sqlcipher/qt5-sqlcipher-0.1.1_pre20171123.ebuild
parent89c6c06b8c42107dd231687a1012354e7d3039fc (diff)
gentoo resync : 01.12.2017
Diffstat (limited to 'dev-db/qt5-sqlcipher/qt5-sqlcipher-0.1.1_pre20171123.ebuild')
-rw-r--r--dev-db/qt5-sqlcipher/qt5-sqlcipher-0.1.1_pre20171123.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-db/qt5-sqlcipher/qt5-sqlcipher-0.1.1_pre20171123.ebuild b/dev-db/qt5-sqlcipher/qt5-sqlcipher-0.1.1_pre20171123.ebuild
new file mode 100644
index 000000000000..75caf3f0bb1a
--- /dev/null
+++ b/dev-db/qt5-sqlcipher/qt5-sqlcipher-0.1.1_pre20171123.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Qt SQL driver plugin for SQLCipher"
+HOMEPAGE="https://github.com/blizzard4591/qt5-sqlcipher"
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
+
+LICENSE="LGPL-2.1" # version 2.1 only
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=">=dev-db/sqlcipher-3.4.1
+ >=dev-qt/qtcore-5.7.1:5=
+ >=dev-qt/qtsql-5.7.1:5=[sqlite]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+DOCS=(README.md)
+
+src_prepare() {
+ eapply "${FILESDIR}"/${PN}-install-path.patch
+ sed -i -e "s/@LIBDIR@/$(get_libdir)/" CMakeLists.txt || die
+ cmake-utils_src_prepare
+}
+
+src_test() {
+ cd "${BUILD_DIR}" || die
+ ./qsqlcipher-test || die
+}