summaryrefslogtreecommitdiff
path: root/dev-db/pspg/pspg-5.8.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-28 16:53:39 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-28 16:53:39 +0000
commitb35600c999baee29d87c2748f7207ce79ca87067 (patch)
treec2724e0a74f5c08fb608a856be4b111e2a380c2d /dev-db/pspg/pspg-5.8.1.ebuild
parent3e690338421a6b64f6f44aa03db7416d75e0633a (diff)
gentoo auto-resync : 28:11:2023 - 16:53:39
Diffstat (limited to 'dev-db/pspg/pspg-5.8.1.ebuild')
-rw-r--r--dev-db/pspg/pspg-5.8.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-db/pspg/pspg-5.8.1.ebuild b/dev-db/pspg/pspg-5.8.1.ebuild
new file mode 100644
index 000000000000..36f09ddb9371
--- /dev/null
+++ b/dev-db/pspg/pspg-5.8.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A better pager for CLI database clients, and can substitute psql"
+HOMEPAGE="https://github.com/okbob/pspg"
+SRC_URI="https://github.com/okbob/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="postgres"
+RESTRICT="test"
+
+RDEPEND="
+sys-libs/ncurses:=
+sys-libs/readline:=
+postgres? ( dev-db/postgresql:= )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf $(use_with postgres postgresql)
+}