summaryrefslogtreecommitdiff
path: root/dev-db/phppgadmin/phppgadmin-7.14.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-23 23:21:09 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-23 23:21:09 +0100
commit3c246ed172bd795a519ba659ba32c9e91f6bedde (patch)
treee645817a0c9a25a248315adfe5ed38e76eb3d49d /dev-db/phppgadmin/phppgadmin-7.14.5.ebuild
parentb42afc2e976bde12586d398e7cb53b7910866059 (diff)
gentoo auto-resync : 23:09:2023 - 23:21:08
Diffstat (limited to 'dev-db/phppgadmin/phppgadmin-7.14.5.ebuild')
-rw-r--r--dev-db/phppgadmin/phppgadmin-7.14.5.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-db/phppgadmin/phppgadmin-7.14.5.ebuild b/dev-db/phppgadmin/phppgadmin-7.14.5.ebuild
new file mode 100644
index 000000000000..e0f1422ca113
--- /dev/null
+++ b/dev-db/phppgadmin/phppgadmin-7.14.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp
+
+MY_P="phpPgAdmin-${PV}-mod"
+
+DESCRIPTION="Web-based administration for Postgres database in php"
+HOMEPAGE="http://phppgadmin.sourceforge.net/"
+SRC_URI="https://github.com/ReimuHakurei/phpPgAdmin/archive/refs/tags/v${PV}-mod.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-lang/php[postgres,session,unicode]"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ webapp_src_preinst
+
+ local doc
+ local docs="BUGS CREDITS DEVELOPERS FAQ HISTORY INSTALL TODO TRANSLATORS"
+ dodoc ${docs}
+ mv conf/config.inc.php-dist conf/config.inc.php || die
+
+ cp -r * "${D}${MY_HTDOCSDIR}"
+ for doc in ${docs} INSTALL LICENSE; do
+ rm -f "${D}${MY_HTDOCSDIR}/${doc}" || die
+ done
+
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/config.inc.php
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+}