summaryrefslogtreecommitdiff
path: root/dev-db/pgrouting
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-28 20:40:51 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-28 20:40:51 +0000
commit9c417bacd51da6d8b57fa9f37425161d30d4b95b (patch)
tree47c9d6e4243f39a1f48afd54c969b65b00a5c649 /dev-db/pgrouting
parentd934827bf44b7cfcf6711964418148fa60877668 (diff)
gentoo resync : 28.11.2020
Diffstat (limited to 'dev-db/pgrouting')
-rw-r--r--dev-db/pgrouting/Manifest2
-rw-r--r--dev-db/pgrouting/pgrouting-3.1.1.ebuild56
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-db/pgrouting/Manifest b/dev-db/pgrouting/Manifest
index 79c75c7489c2..27552278d5d3 100644
--- a/dev-db/pgrouting/Manifest
+++ b/dev-db/pgrouting/Manifest
@@ -1,3 +1,5 @@
DIST pgrouting-2.6.2.tar.gz 6065517 BLAKE2B e27e28cf988040de1e894a857e3d210bc7676271f69d898afc2d6116d5b88d87404723b2cb1283ef77b4449b4aa62a03e2dbcd489ac641a4721a596d29f8fecd SHA512 6e37f66e631d0cc87e135be7d095822aae21656bb56b3d18afa5bececaad8cee6324d37e8e152bbf69e3374ded1f10aa4b9a4c52b873e3a4c43e73cd877fddcb
+DIST pgrouting-3.1.1.tar.gz 6133979 BLAKE2B b7657eeb88773773e6166190cda73d9e657774ff81ce7e9f005333a8dcb9d56587d4a793410356092bb1623ec287549dbc60d814b1d5156ff28301503acee776 SHA512 73285d2d47be844203df136b8a8c13d1672ad8c2dac44a1ff7ce16e4676043692a8f2a60a305542132891da83560c49c5eaeb7712e3e3dd250cd8fd550260d4a
EBUILD pgrouting-2.6.2-r1.ebuild 1224 BLAKE2B d1f10f219e584e2167fbb3351cc35424fb35f10def7e7ba115aa4bec54c259f43e771e47f52d7fddf19c838117d0d265252d4886599ec401020287f590223d35 SHA512 6087d2e8e20c815defe78c440d5ba58e30de353e8ee0722b7347bff79c32ae7abc1d46d48b95c32c0b28db55043f198609217053012134dbfe27b1e879c06eb4
+EBUILD pgrouting-3.1.1.ebuild 1092 BLAKE2B 9e255ade68e57e65f0fb38dc36985f2eaf77323a0e2f769d86031caece6bd08544397b2be8ace08003173b9626663158c54483a0cefc50173117a5991fd6ead3 SHA512 c17720ec34aa5c0c97c39c1e428a45415d78c3b099acb6bce34e8644b2f8f3499bb6219e68efcf2752bc6035354fad239f546589503269e7a098a69ff00eda90
MISC metadata.xml 457 BLAKE2B d2432768e9244c7648720e1569195498ffa3bda4f862a5b5a2edbbd4383d3ca0ab83063c1004680ea6eb662d74f13c2ec4991baa25365ae9ae8f513b93c973b1 SHA512 bbfc5eec69256ba3addfe5c3158b11b4561b347682474ac2f5ac4cb3be8ca30df130957c751f09d761d3a3d8ad62cf3e59193414a31a9b46d793084285c9406d
diff --git a/dev-db/pgrouting/pgrouting-3.1.1.ebuild b/dev-db/pgrouting/pgrouting-3.1.1.ebuild
new file mode 100644
index 000000000000..519683a61f95
--- /dev/null
+++ b/dev-db/pgrouting/pgrouting-3.1.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_BUILD_TYPE="Release"
+#CMAKE_MAKEFILE_GENERATOR=emake
+
+POSTGRES_COMPAT=( 9.{5..6} {10..13} )
+POSTGRES_USEDEP="server"
+
+inherit cmake postgres-multi
+
+DESCRIPTION="pgRouting extends PostGIS and PostgreSQL with geospatial routing functionality."
+HOMEPAGE="https://pgrouting.org/"
+LICENSE="GPL-2 MIT Boost-1.0"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+SRC_URI="https://github.com/pgRouting/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+IUSE=""
+
+RDEPEND="${POSTGRES_DEP}
+ >=dev-db/postgis-2.0
+ dev-libs/boost
+ sci-mathematics/cgal
+"
+DEPEND="${RDEPEND}"
+
+# Needs a running psql instance, doesn't work out of the box
+RESTRICT="test"
+
+src_prepare() {
+ cmake_src_prepare
+ postgres-multi_src_prepare
+}
+
+my_src_configure() {
+ local mycmakeargs=(
+ -DPOSTGRESQL_BIN="$($PG_CONFIG --bindir)"
+ )
+
+ cmake_src_configure
+}
+
+src_configure() {
+ postgres-multi_foreach my_src_configure
+}
+
+src_compile() {
+ postgres-multi_foreach cmake_build
+}
+
+src_install() {
+ postgres-multi_foreach cmake_src_install
+}