summaryrefslogtreecommitdiff
path: root/dev-db/pgpool2/pgpool2-3.7.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-db/pgpool2/pgpool2-3.7.1.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-db/pgpool2/pgpool2-3.7.1.ebuild')
-rw-r--r--dev-db/pgpool2/pgpool2-3.7.1.ebuild98
1 files changed, 0 insertions, 98 deletions
diff --git a/dev-db/pgpool2/pgpool2-3.7.1.ebuild b/dev-db/pgpool2/pgpool2-3.7.1.ebuild
deleted file mode 100644
index fe57ae924343..000000000000
--- a/dev-db/pgpool2/pgpool2-3.7.1.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-POSTGRES_COMPAT=( 9.{3..6} 10 )
-
-inherit postgres-multi
-
-MY_P="${PN/2/-II}-${PV}"
-
-DESCRIPTION="Connection pool server for PostgreSQL"
-HOMEPAGE="http://www.pgpool.net/"
-SRC_URI="http://www.pgpool.net/download.php?f=${MY_P}.tar.gz -> ${MY_P}.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-
-KEYWORDS="~amd64 ~x86"
-
-IUSE="doc memcached pam ssl static-libs"
-
-RDEPEND="
- ${POSTGRES_DEP}
- net-libs/libnsl:0=
- memcached? ( dev-libs/libmemcached )
- pam? ( sys-auth/pambase )
- ssl? ( dev-libs/openssl:* )
-"
-DEPEND="${RDEPEND}
- sys-devel/bison
- !!dev-db/pgpool
-"
-
-S=${WORKDIR}/${MY_P}
-
-pkg_setup() {
- postgres_new_user pgpool
-
- postgres-multi_pkg_setup
-}
-
-src_prepare() {
- eapply "${FILESDIR}/pgpool_run_paths-3.6.5.patch"
-
- postgres-multi_src_prepare
-}
-
-src_configure() {
- local myconf
- use memcached && \
- myconf="--with-memcached=\"${EROOT%/}/usr/include/libmemcached\""
- use pam && myconf+=' --with-pam'
-
- postgres-multi_foreach econf \
- --disable-rpath \
- --sysconfdir="${EROOT%/}/etc/${PN}" \
- --with-pgsql-includedir='/usr/include/postgresql-@PG_SLOT@' \
- --with-pgsql-libdir="/usr/$(get_libdir)/postgresql-@PG_SLOT@/$(get_libdir)" \
- $(use_with ssl openssl) \
- $(use_enable static-libs static) \
- ${myconf}
-}
-
-src_compile() {
- # Even though we're only going to do an install for the best slot
- # available, the extension bits in src/sql need some things outside
- # of that directory built, too.
- postgres-multi_foreach emake
- postgres-multi_foreach emake -C src/sql
-}
-
-src_install() {
- # We only need the best stuff installed
- postgres-multi_forbest emake DESTDIR="${D}" install
-
- # Except for the extension and .so files that each PostgreSQL slot needs
- postgres-multi_foreach emake DESTDIR="${D}" -C src/sql install
-
- newinitd "${FILESDIR}/${PN}.initd" ${PN}
- newconfd "${FILESDIR}/${PN}.confd" ${PN}
-
- # Documentation!
- dodoc NEWS TODO
- doman doc/src/sgml/man{1,8}/*
- use doc && dodoc -r doc/src/sgml/html
-
- # Examples and extras
- # mv some files that get installed to /usr/share/pgpool-II so that
- # they all wind up in the same place
- mv "${ED%/}/usr/share/${PN/2/-II}" "${ED%/}/usr/share/${PN}" || die
- into "/usr/share/${PN}"
- dobin src/sample/{pgpool_recovery,pgpool_recovery_pitr,pgpool_remote_start}
- insinto "/usr/share/${PN}"
- doins src/sample/{{pcp,pgpool,pool_hba}.conf.sample*,pgpool.pam}
-
- # One more thing: Evil la files!
- find "${ED}" -name '*.la' -exec rm -f {} +
-}