summaryrefslogtreecommitdiff
path: root/dev-db/opendbx/opendbx-1.4.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-db/opendbx/opendbx-1.4.5-r1.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-db/opendbx/opendbx-1.4.5-r1.ebuild')
-rw-r--r--dev-db/opendbx/opendbx-1.4.5-r1.ebuild64
1 files changed, 0 insertions, 64 deletions
diff --git a/dev-db/opendbx/opendbx-1.4.5-r1.ebuild b/dev-db/opendbx/opendbx-1.4.5-r1.ebuild
deleted file mode 100644
index c069c4e62341..000000000000
--- a/dev-db/opendbx/opendbx-1.4.5-r1.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit flag-o-matic multilib
-
-DESCRIPTION="OpenDBX - A database abstraction layer"
-HOMEPAGE="https://www.linuxnetworks.de/doc/index.php/OpenDBX"
-SRC_URI="https://www.linuxnetworks.de/opendbx/download/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="firebird +mysql oracle postgres sqlite"
-RESTRICT="firebird? ( bindist )"
-
-DEPEND="mysql? ( virtual/mysql )
- postgres? ( dev-db/postgresql:* )
- sqlite? ( dev-db/sqlite:3 )
- oracle? ( dev-db/oracle-instantclient-basic )
- firebird? ( dev-db/firebird )"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- if ! ( use firebird || use mysql || use oracle || use postgres || use sqlite )
- then
- ewarn "You should enable at least one of the following USE flags:"
- ewarn "firebird, mysql, oracle, postgres or sqlite"
- fi
-
- if use oracle && [[ ! -d ${ORACLE_HOME} ]]
- then
- die "Oracle support requested, but ORACLE_HOME not set to a valid directory!"
- fi
-
- use mysql && append-cppflags -I/usr/include/mysql
- use firebird && append-cppflags -I/opt/firebird/include
- use oracle && append-ldflags -L"${ORACLE_HOME}"/lib
-}
-
-src_configure() {
- local backends=""
-
- use firebird && backends="${backends} firebird"
- use mysql && backends="${backends} mysql"
- use oracle && backends="${backends} oracle"
- use postgres && backends="${backends} pgsql"
- use sqlite && backends="${backends} sqlite3"
-
- econf --with-backends="${backends}"
-}
-
-src_compile() {
- # bug #322221
- emake -j1
-}
-
-src_install() {
- emake -j1 install DESTDIR="${D}"
- dodoc AUTHORS ChangeLog README
-
- rm -f "${D}"/usr/$(get_libdir)/opendbx/*.{a,la}
-}