summaryrefslogtreecommitdiff
path: root/dev-db/ocp/ocp-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-db/ocp/ocp-9999.ebuild
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-db/ocp/ocp-9999.ebuild')
-rw-r--r--dev-db/ocp/ocp-9999.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/dev-db/ocp/ocp-9999.ebuild b/dev-db/ocp/ocp-9999.ebuild
index 5c6591bf5df3..baeb53e6decb 100644
--- a/dev-db/ocp/ocp-9999.ebuild
+++ b/dev-db/ocp/ocp-9999.ebuild
@@ -1,15 +1,17 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
DESCRIPTION="Oracle copy tool"
HOMEPAGE="https://github.com/maxsatula/ocp"
+inherit toolchain-funcs
+
if [[ ${PV} == *9999 ]]; then
EGIT_REPO_URI="https://github.com/maxsatula/ocp.git"
EGIT_BRANCH="develop"
- inherit git-r3 autotools
+ inherit autotools git-r3
else
SRC_URI="https://github.com/maxsatula/ocp/releases/download/v${PV}/${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
@@ -27,6 +29,10 @@ DEPEND="
dev-db/oracle-instantclient[sdk]
${RDEPEND}"
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
src_prepare() {
default