summaryrefslogtreecommitdiff
path: root/dev-db/mysqltuner/mysqltuner-1.7.15.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
commitb24bd25253fe093f722ab576d29fdc41d04cb1ee (patch)
tree0fcf2afd9f852c4d4c291cf8afaa2c244d598105 /dev-db/mysqltuner/mysqltuner-1.7.15.ebuild
parent121ed4eec41fbf03e1998d09eede1bf449da63b9 (diff)
gentoo resync : 02.08.2019
Diffstat (limited to 'dev-db/mysqltuner/mysqltuner-1.7.15.ebuild')
-rw-r--r--dev-db/mysqltuner/mysqltuner-1.7.15.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-db/mysqltuner/mysqltuner-1.7.15.ebuild b/dev-db/mysqltuner/mysqltuner-1.7.15.ebuild
new file mode 100644
index 000000000000..4d6ffb075a99
--- /dev/null
+++ b/dev-db/mysqltuner/mysqltuner-1.7.15.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN=MySQLTuner-perl
+
+DESCRIPTION="MySQLTuner is a high-performance MySQL tuning script"
+HOMEPAGE="https://github.com/major/MySQLTuner-perl"
+SRC_URI="https://github.com/major/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/perl
+ virtual/mysql
+ virtual/perl-Getopt-Long"
+
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ # Fix password detecting under MySQL 5.7 upstream #442 #427 #441
+ "${FILESDIR}/${P}-password.patch" )
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+DOCS=( USAGE.md CONTRIBUTING.md INTERNALS.md basic_passwords.txt vulnerabilities.csv )
+
+src_install() {
+ einstalldocs
+
+ newbin "${PN}.pl" "${PN}"
+
+ # Passwords and vulnerabilities are meant to be fed
+ # to the script uncompressed.
+ docompress -x "/usr/share/doc/${PF}/basic_passwords.txt" "/usr/share/doc/${PF}/vulnerabilities.csv"
+}