summaryrefslogtreecommitdiff
path: root/dev-db/mysql-udf-ipv6/mysql-udf-ipv6-0.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-db/mysql-udf-ipv6/mysql-udf-ipv6-0.4.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-db/mysql-udf-ipv6/mysql-udf-ipv6-0.4.ebuild')
-rw-r--r--dev-db/mysql-udf-ipv6/mysql-udf-ipv6-0.4.ebuild68
1 files changed, 0 insertions, 68 deletions
diff --git a/dev-db/mysql-udf-ipv6/mysql-udf-ipv6-0.4.ebuild b/dev-db/mysql-udf-ipv6/mysql-udf-ipv6-0.4.ebuild
deleted file mode 100644
index e7bcc4490033..000000000000
--- a/dev-db/mysql-udf-ipv6/mysql-udf-ipv6-0.4.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit eutils toolchain-funcs
-
-MY_REV="01c591b05b79" # checkout revision
-MY_USR="watchmouse" # user name
-
-MY_P="${MY_USR}-${PN}-${MY_REV}"
-
-DESCRIPTION="IPv6 and internationalized domain (IDNA) functions for MySQL"
-HOMEPAGE="http://labs.watchmouse.com/2009/10/extending-mysql-5-with-ipv6-functions/"
-SRC_URI="https://bitbucket.org/${MY_USR}/${PN}/get/${MY_REV}.tar.bz2 -> ${MY_P}.tar.bz2"
-
-LICENSE="EUPL-1.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="idn"
-
-DEPEND=">=virtual/mysql-5.1
- idn? ( net-dns/libidn )"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-# compile helper
-_compile() {
- local CC="$(tc-getCC)"
- echo "${CC} ${@}" && "${CC}" "${@}"
-}
-
-pkg_setup() {
- MYSQL_PLUGINDIR="$(mysql_config --plugindir)"
- MYSQL_INCLUDE="$(mysql_config --include)"
-}
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-warnings.patch"
-}
-
-src_compile() {
- _compile ${CFLAGS} -Wall -fPIC ${MYSQL_INCLUDE} \
- -shared ${LDFLAGS} -o mysql_udf_ipv6.so mysql_udf_ipv6.c
-
- if use idn; then
- _compile ${CFLAGS} -Wall -fPIC ${MYSQL_INCLUDE} -lidn \
- -shared ${LDFLAGS} -o mysql_udf_idna.so mysql_udf_idna.c
- fi
-}
-
-src_install() {
- exeinto "${MYSQL_PLUGINDIR}"
- doexe mysql_udf_*.so
- newdoc Changelog ChangeLog
- dodoc README
-}
-
-pkg_postinst() {
- elog
- elog "Please have a look at the documentation, how to"
- elog "enable/disable the UDF functions of ${PN}."
- elog
- elog "The documentation is located here:"
- elog "/usr/share/doc/${PF}"
- elog
-}