summaryrefslogtreecommitdiff
path: root/dev-db/mysql-connector-c/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-11-26 11:42:28 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-11-26 11:42:28 +0000
commit89c6c06b8c42107dd231687a1012354e7d3039fc (patch)
treedad94f4da8a6694f3cb99f7048be2f9cf5f78f97 /dev-db/mysql-connector-c/files
parent796cae72cf9ed18ba01256ac1f83a686a2a76036 (diff)
gentoo resync : 26.11.2017
Diffstat (limited to 'dev-db/mysql-connector-c/files')
-rw-r--r--dev-db/mysql-connector-c/files/20028_all_mysql-5.6-gcc7.patch13
-rw-r--r--dev-db/mysql-connector-c/files/conn-c-includes.patch15
-rw-r--r--dev-db/mysql-connector-c/files/openssl-cmake-detection.patch12
3 files changed, 13 insertions, 27 deletions
diff --git a/dev-db/mysql-connector-c/files/20028_all_mysql-5.6-gcc7.patch b/dev-db/mysql-connector-c/files/20028_all_mysql-5.6-gcc7.patch
new file mode 100644
index 000000000000..cf8caedb7f1b
--- /dev/null
+++ b/dev-db/mysql-connector-c/files/20028_all_mysql-5.6-gcc7.patch
@@ -0,0 +1,13 @@
+diff --git a/sql-common/client_authentication.cc b/sql-common/client_authentication.cc
+index eaeb2d4..035ecd2 100644
+--- a/sql-common/client_authentication.cc
++++ b/sql-common/client_authentication.cc
+@@ -84,7 +84,7 @@ RSA *rsa_init(MYSQL *mysql)
+
+ if (mysql->options.extension != NULL &&
+ mysql->options.extension->server_public_key_path != NULL &&
+- mysql->options.extension->server_public_key_path != '\0')
++ mysql->options.extension->server_public_key_path[0] != '\0')
+ {
+ pub_key_file= fopen(mysql->options.extension->server_public_key_path,
+ "r");
diff --git a/dev-db/mysql-connector-c/files/conn-c-includes.patch b/dev-db/mysql-connector-c/files/conn-c-includes.patch
deleted file mode 100644
index fcde71f3f4ee..000000000000
--- a/dev-db/mysql-connector-c/files/conn-c-includes.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff -aurN a/include/CMakeLists.txt b/include/CMakeLists.txt
---- a/include/CMakeLists.txt 2015-07-14 13:06:04.424091000 -0400
-+++ b/include/CMakeLists.txt 2015-07-14 13:24:43.434091000 -0400
-@@ -55,6 +55,11 @@
- byte_order_generic_x86.h
- little_endian.h
- big_endian.h
-+ my_thread_local.h
-+ thr_cond.h
-+ thr_lock.h
-+ thr_mutex.h
-+ thr_rwlock.h
- ${HEADERS_GEN_CONFIGURE}
- )
-
diff --git a/dev-db/mysql-connector-c/files/openssl-cmake-detection.patch b/dev-db/mysql-connector-c/files/openssl-cmake-detection.patch
deleted file mode 100644
index 3a5f53e7ba35..000000000000
--- a/dev-db/mysql-connector-c/files/openssl-cmake-detection.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -aurN a/cmake/ssl.cmake b/cmake/ssl.cmake
---- a/cmake/ssl.cmake 2014-11-21 00:39:51.000000000 -0500
-+++ b/cmake/ssl.cmake 2015-01-27 08:45:36.771744344 -0500
-@@ -166,7 +166,7 @@
- # Encoded as MNNFFPPS: major minor fix patch status
- FILE(STRINGS "${OPENSSL_INCLUDE_DIR}/openssl/opensslv.h"
- OPENSSL_VERSION_NUMBER
-- REGEX "^#define[\t ]+OPENSSL_VERSION_NUMBER[\t ]+0x[0-9].*"
-+ REGEX "^#[\t ]*define[\t ]+OPENSSL_VERSION_NUMBER[\t ]+0x[0-9].*"
- )
- STRING(REGEX REPLACE
- "^.*OPENSSL_VERSION_NUMBER[\t ]+0x([0-9]).*$" "\\1"