summaryrefslogtreecommitdiff
path: root/dev-db/mysql-cluster/mysql-cluster-7.4.21.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
commita978c074e4272bb901fbe4a10de0a7b2af574f17 (patch)
tree8c764c1cc0576389ce22abd317bceba71ea5732d /dev-db/mysql-cluster/mysql-cluster-7.4.21.ebuild
parent40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (diff)
gentoo resync : 04.05.2021
Diffstat (limited to 'dev-db/mysql-cluster/mysql-cluster-7.4.21.ebuild')
-rw-r--r--dev-db/mysql-cluster/mysql-cluster-7.4.21.ebuild15
1 files changed, 4 insertions, 11 deletions
diff --git a/dev-db/mysql-cluster/mysql-cluster-7.4.21.ebuild b/dev-db/mysql-cluster/mysql-cluster-7.4.21.ebuild
index ad252c1349b3..d78696ae60ea 100644
--- a/dev-db/mysql-cluster/mysql-cluster-7.4.21.ebuild
+++ b/dev-db/mysql-cluster/mysql-cluster-7.4.21.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -24,12 +24,11 @@ HOMEPAGE="https://mysql.com/"
DESCRIPTION="An enhanced, drop-in replacement for MySQL"
LICENSE="GPL-2"
SLOT="0"
-IUSE="client-libs debug extraengine jemalloc latin1 libressl numa
+IUSE="client-libs debug extraengine jemalloc latin1 numa
+perl profiling selinux +server static static-libs systemtap tcmalloc
test yassl"
-# Tests always fail when libressl is enabled due to hard-coded ciphers in the tests
-RESTRICT="!test? ( test ) libressl? ( test )"
+RESTRICT="!test? ( test )"
REQUIRED_USE="?? ( tcmalloc jemalloc )
static? ( yassl )"
@@ -80,8 +79,7 @@ COMMON_DEPEND="
tcmalloc? ( dev-util/google-perftools:0= )
systemtap? ( >=dev-util/systemtap-1.3:0= )
!yassl? (
- !libressl? ( >=dev-libs/openssl-1.0.0:0= )
- libressl? ( dev-libs/libressl:0= )
+ >=dev-libs/openssl-1.0.0:0=
)
>=sys-libs/zlib-1.2.3:0=
sys-libs/ncurses:0=
@@ -197,11 +195,6 @@ src_prepare() {
echo > "${S}/support-files/SELinux/CMakeLists.txt" || die
fi
- if use libressl ; then
- sed -i 's/OPENSSL_MAJOR_VERSION STREQUAL "1"/OPENSSL_MAJOR_VERSION STREQUAL "2"/' \
- "${S}/cmake/ssl.cmake" || die
- fi
-
local plugin
local server_plugins=( semisync )
local test_plugins=( audit_null daemon_example fulltext )