summaryrefslogtreecommitdiff
path: root/dev-db/mysql++/mysql++-3.2.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-db/mysql++/mysql++-3.2.3.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-db/mysql++/mysql++-3.2.3.ebuild')
-rw-r--r--dev-db/mysql++/mysql++-3.2.3.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-db/mysql++/mysql++-3.2.3.ebuild b/dev-db/mysql++/mysql++-3.2.3.ebuild
new file mode 100644
index 000000000000..83594c55eda5
--- /dev/null
+++ b/dev-db/mysql++/mysql++-3.2.3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools libtool flag-o-matic
+
+DESCRIPTION="C++ API interface to the MySQL database"
+HOMEPAGE="http://tangentsoft.net/mysql++/"
+SRC_URI="http://www.tangentsoft.net/mysqlpp/releases/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc"
+
+RDEPEND="virtual/libmysqlclient:="
+DEPEND="${RDEPEND}"
+DOCS=( CREDITS.txt HACKERS.txt Wishlist doc/ssqls-pretty )
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.2.1-gold.patch
+ "${FILESDIR}"/${PN}-3.2.3-mariadb-10.2.patch
+ "${FILESDIR}"/${PN}-3.2.3-as-needed.patch
+)
+
+src_prepare() {
+ # Bug filed upstream about deprecated std::auto_ptr
+ append-cxxflags $(test-flags-CXX -Wno-deprecated-declarations)
+ # Bad symlink for libtool in the archive
+ rm "${S}/ltmain.sh" || die
+
+ default
+
+ _elibtoolize --auto-ltdl --install --copy --force
+ elibtoolize
+ # Current MySQL libraries are always with threads and slowly being removed
+ sed -i -e "s/mysqlclient_r/mysqlclient/" "${S}/configure" || die
+ rm "${S}/doc/"README-*-RPM.txt || die
+}
+
+src_configure() {
+ local myconf=(
+ --enable-thread-check
+ --with-mysql="${EPREFIX}/usr"
+ --with-mysql-lib="${EPREFIX}$(mysql_config --variable=pkglibdir)"
+ --with-mysql-include="${EPREFIX}$(mysql_config --variable=pkgincludedir)"
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ # install the docs and HTML pages
+ use doc && dodoc -r doc/pdf/ doc/refman/ doc/userman/ doc/html/
+}