summaryrefslogtreecommitdiff
path: root/dev-db/metakit/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-db/metakit/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-db/metakit/files')
-rw-r--r--dev-db/metakit/files/metakit-2.4.9.7-linking.patch45
-rw-r--r--dev-db/metakit/files/metakit-2.4.9.7-tcltk86.patch70
2 files changed, 115 insertions, 0 deletions
diff --git a/dev-db/metakit/files/metakit-2.4.9.7-linking.patch b/dev-db/metakit/files/metakit-2.4.9.7-linking.patch
new file mode 100644
index 000000000000..55453a2d8e4a
--- /dev/null
+++ b/dev-db/metakit/files/metakit-2.4.9.7-linking.patch
@@ -0,0 +1,45 @@
+ unix/Makefile.in | 10 +++++-----
+ 1 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/unix/Makefile.in b/unix/Makefile.in
+index bf187ba..763558f 100755
+--- a/unix/Makefile.in
++++ b/unix/Makefile.in
+@@ -43,7 +43,7 @@ CXX_FLAGS = @CPPFLAGS@ @CXXFLAGS@ @MK_THREADS@ @SHLIB_CFLAGS@ \
+ # (e.g. in Mk4py). This does not affect standard operation, *only* errors.
+ # Happens in gcc 2.95.3, it has been disabled for now (even though slower).
+ #CXXFLAGS = -fomit-frame-pointer $(CXX_FLAGS)
+-CXXFLAGS = $(CXX_FLAGS)
++CXXFLAGS += -I$(srcdir)/../include
+ #CXXFLAGS = -Dq4_CHECK $(CXX_FLAGS)
+ #CXXFLAGS = -Wall -pedantic -Wno-unused $(CXX_FLAGS)
+
+@@ -134,24 +134,24 @@ libmk4$(LIB_SUFFIX): $(LOBJS)
+ ranlib $@
+
+ libmk4$(SHLIB_SUFFIX): $(LOBJS) $(LINK_SPECIAL_FILES)
+- $(SHLIB_LD) -o $@ $(LOBJS) $(LINK_SPECIAL_FLAGS)
++ $(SHLIB_LD) $(LDFLAGS) -o $@ $(LOBJS) $(LINK_SPECIAL_FLAGS)
+
+ Mk4tcl$(LIB_SUFFIX): mk4tcl.o mk4too.o $(LOBJS)
+ ar rcu $@ mk4tcl.o mk4too.o $(LOBJS)
+ ranlib $@
+
+ Mk4tcl$(SHLIB_SUFFIX): mk4tcl.o mk4too.o $(LOBJS) $(LINK_SPECIAL_FILES)
+- $(SHLIB_LD) -o $@ mk4tcl.o mk4too.o $(LOBJS) $(LINK_SPECIAL_FLAGS)
++ $(SHLIB_LD) $(LDFLAGS) -o $@ mk4tcl.o mk4too.o $(LOBJS) $(LINK_SPECIAL_FLAGS)
+
+ Mk4py$(LIB_SUFFIX): $(PYOBJS) $(LOBJS)
+ ar cru $@ $(PYOBJS) $(LOBJS)
+ ranlib $@
+
+ Mk4py$(SHLIB_SUFFIX): $(PYOBJS) $(LOBJS) $(LINK_SPECIAL_FILES)
+- $(SHLIB_LD) -o $@ $(PYOBJS) $(LOBJS) $(LINK_SPECIAL_FLAGS)
++ $(SHLIB_LD) $(LDFLAGS) -o $@ $(PYOBJS) -L. -lmk4 $(LINK_SPECIAL_FLAGS) $(PYTHON_LIB)
+
+ Mk4lua$(SHLIB_SUFFIX): mk4lua.o $(LOBJS) $(LINK_SPECIAL_FILES)
+- $(SHLIB_LD) -o $@ mk4lua.o $(LOBJS) $(LINK_SPECIAL_FLAGS)
++ $(SHLIB_LD) $(LDFLAGS) -o $@ mk4lua.o $(LOBJS) $(LINK_SPECIAL_FLAGS)
+
+ demo: $(srcdir)/../demos/demo.cpp libmk4$(LIBEXT)
+ $(CXX) $(CXX_SWITCHES) -o $@$(EXEEXT) \
diff --git a/dev-db/metakit/files/metakit-2.4.9.7-tcltk86.patch b/dev-db/metakit/files/metakit-2.4.9.7-tcltk86.patch
new file mode 100644
index 000000000000..cbf4ce3549f6
--- /dev/null
+++ b/dev-db/metakit/files/metakit-2.4.9.7-tcltk86.patch
@@ -0,0 +1,70 @@
+ tcl/mk4tcl.cpp | 10 +++++++---
+ tcl/mk4too.cpp | 6 +++++-
+ 2 files changed, 12 insertions(+), 4 deletions(-)
+
+diff --git a/tcl/mk4tcl.cpp b/tcl/mk4tcl.cpp
+index 049bf8e..8d2249e 100755
+--- a/tcl/mk4tcl.cpp
++++ b/tcl/mk4tcl.cpp
+@@ -28,6 +28,10 @@
+ #define MyInitStubs(x) 1
+ #endif
+
++#if 10 * TCL_MAJOR_VERSION + TCL_MINOR_VERSION < 86
++#define Tcl_GetErrorLine(interp) (interp)->errorLine
++#endif
++
+ // definition of valid property name - alpha numerics, underscore, percent,
+ // or any extended utf-8 character
+ #define ISNAME(c) (isalnum((c)) || (c) == '_' || (c) == '%' || (c) & 0x80)
+@@ -979,7 +983,7 @@ const c4_Property &AsProperty(Tcl_Obj *objPtr, const c4_View &view_) {
+ void *tag = (&view_[0])._seq; // horrific hack to get at c4_Sequence pointer
+ if (objPtr->typePtr != &mkPropertyType || objPtr
+ ->internalRep.twoPtrValue.ptr1 != tag) {
+- Tcl_ObjType *oldTypePtr = objPtr->typePtr;
++ CONST86 Tcl_ObjType *oldTypePtr = objPtr->typePtr;
+
+ char type = 'S';
+
+@@ -1083,7 +1087,7 @@ int SetCursorFromAny(Tcl_Interp *interp, Tcl_Obj *objPtr) {
+ }
+
+ if (objPtr->typePtr != &mkCursorType) {
+- Tcl_ObjType *oldTypePtr = objPtr->typePtr;
++ CONST86 Tcl_ObjType *oldTypePtr = objPtr->typePtr;
+
+ const char *string = Tcl_GetStringFromObj(objPtr, 0);
+
+@@ -2156,7 +2160,7 @@ int MkTcl::LoopCmd() {
+ _error = TCL_OK;
+ else if (_error == TCL_ERROR) {
+ char msg[100];
+- sprintf(msg, "\n (\"mk::loop\" body line %d)", interp->errorLine);
++ sprintf(msg, "\n (\"mk::loop\" body line %d)", Tcl_GetErrorLine(interp));
+ Tcl_AddObjErrorInfo(interp, msg, - 1);
+ }
+ break;
+diff --git a/tcl/mk4too.cpp b/tcl/mk4too.cpp
+index 7c845c0..ffcbc4e 100644
+--- a/tcl/mk4too.cpp
++++ b/tcl/mk4too.cpp
+@@ -7,6 +7,10 @@
+ #include <stdio.h>
+ #include <string.h>
+
++#if 10 * TCL_MAJOR_VERSION + TCL_MINOR_VERSION < 86
++#define Tcl_GetErrorLine(interp) (interp)->errorLine
++#endif
++
+ ///////////////////////////////////////////////////////////////////////////////
+ // Defined in this file:
+
+@@ -612,7 +616,7 @@ int MkView::LoopCmd() {
+ _error = TCL_OK;
+ else if (_error == TCL_ERROR) {
+ char msg[100];
+- sprintf(msg, "\n (\"mk::loop\" body line %d)", interp->errorLine);
++ sprintf(msg, "\n (\"mk::loop\" body line %d)", Tcl_GetErrorLine(interp));
+ Tcl_AddObjErrorInfo(interp, msg, - 1);
+ }
+ break;