summaryrefslogtreecommitdiff
path: root/dev-db/maatkit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-db/maatkit
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-db/maatkit')
-rw-r--r--dev-db/maatkit/Manifest5
-rw-r--r--dev-db/maatkit/maatkit-7540-r1.ebuild110
-rw-r--r--dev-db/maatkit/metadata.xml18
3 files changed, 133 insertions, 0 deletions
diff --git a/dev-db/maatkit/Manifest b/dev-db/maatkit/Manifest
new file mode 100644
index 000000000000..b8c911e04ed7
--- /dev/null
+++ b/dev-db/maatkit/Manifest
@@ -0,0 +1,5 @@
+DIST maatkit-7540.tar.gz 1312812 SHA256 618b8ba8f8df1c8ac04d127986a7bb6a834643523000c9c5ea4ee7d95aeef9a8 SHA512 98cb44a5ebce09322b4d9a8cfa9e14e2ccb54ef9e0e8a95ee92b0fee5277f06157415152566497893488967735049d95c6efadc0d57c8a70060c7bc714afef9a WHIRLPOOL 73685d156a750263ec8d8ba6d22c6e96aa98ed2247523b74a336572ef8e6ae8239f84dd2e7839752c921baca55d911195c0bb1e83d42a87b3a721fa7d0e8439d
+EBUILD maatkit-7540-r1.ebuild 2648 SHA256 3f2c18dee8774e27a2fca1e46c1c9163e6fe6aad5852e48a7c7f005f8382be6e SHA512 50bb20b8ed8f7cfe42e672c43803f62cc97756fd268be02e6166e7b184cf2671e8447aa7f12ec29c71872a493fa2b807318faaf62fa1ea94a95aa652bfef33eb WHIRLPOOL 42dd306861048b6b5f458d535ca37b56a5d0325d977169117e70d01ff476a88479491756f90f24172db873a47cd65b03a1ab81093d077b237f4357af9fd7673d
+MISC ChangeLog 2343 SHA256 3c4fb1ae266bc8b652af7f6f36db444545e3934201e7a088178ac6a5840ed700 SHA512 2a02eda8fb258cb0ba272664a76138fa525bcf3c2516e3494387361d59a487e8a033e4bacbd87685acad38a5b364936e16b3ea6fd72d781fcfb3c0598acca170 WHIRLPOOL 229120cb2692aeed1440b0b60ac9b54cb07fa8626df0b09c18984397adaa34394f00b7ca2bdc72ad7d302d301d4eebf214b803ccb05eb6f5df06c547322c56f0
+MISC ChangeLog-2015 4123 SHA256 d1d14f33b16a5b55bdc16f89e261c47471b1b19abc7ce84bf1fe546808d644b5 SHA512 0b9518660d90bda68b4190614a27eb126630ae44119c5fd1a2e4ee9aa4ead33069f1bca8dd589b41a97dfac5df4465b08a6ab7ecc4eeb64ffc3e1f8537e291bf WHIRLPOOL 5be85f36560449bb2c191ff6704a88d76bfce701986382cbd56878c2ec35adfe44590545cd397237f46deb1e1262eff7e680e5fa5cecaeee0551f849c32a46a6
+MISC metadata.xml 775 SHA256 dcc598a66aa7a1ed87b005aacaf7ff9387997e80acddfeb38915ce165b587735 SHA512 280bda9b191976c9b96f2916c93f2d3b29fdcdffe25c2465246d4752023d0c640660206447e9d20922e627e3d789e030f41f4750642ff2f5fffce07f3d59db4a WHIRLPOOL f6d6a61a02ece2b2a7b4c37051784ef0d384db67fc4f0518daae3fec82458029ed89b381480fc5d2d184159e2929d2929d9f645fb73829071cfb24613789b805
diff --git a/dev-db/maatkit/maatkit-7540-r1.ebuild b/dev-db/maatkit/maatkit-7540-r1.ebuild
new file mode 100644
index 000000000000..9cefb50cea68
--- /dev/null
+++ b/dev-db/maatkit/maatkit-7540-r1.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit perl-app perl-module toolchain-funcs
+
+DESCRIPTION="essential command-line utilities for MySQL"
+HOMEPAGE="http://www.maatkit.org/"
+SRC_URI="https://maatkit.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="udf"
+
+COMMON_DEPEND="dev-perl/DBI
+ dev-perl/DBD-mysql
+ virtual/perl-Time-HiRes"
+RDEPEND="${COMMON_DEPEND}
+ virtual/perl-Getopt-Long
+ virtual/perl-Time-Local
+ virtual/perl-Digest-MD5
+ virtual/perl-IO-Compress
+ virtual/perl-File-Temp
+ virtual/perl-File-Spec
+ virtual/perl-Time-HiRes
+ virtual/perl-Scalar-List-Utils
+ dev-perl/TermReadKey"
+DEPEND="${COMMON_DEPEND}
+ udf? ( dev-db/mysql )
+ virtual/perl-ExtUtils-MakeMaker"
+
+mysql-udf_src_compile() {
+ local udfdir="${T}/udf/"
+ mkdir -p "${udfdir}"
+
+ local udfname udffile udfext udfoutpath
+ udfname="${1}"
+ udfext=".so"
+ udffile="${udfname}${udfext}"
+ udfoutpath="${udfdir}/${udffile}"
+ shift
+ CXX="$(tc-getCXX)"
+ local src="$@"
+ if [ -z "$@" ]; then
+ src="${udfname}.cc"
+ fi
+ for f in ${src} ; do
+ [ -f "${f}" ] || \
+ die "UDF ${udfname}: Cannot find source file ${f} to compile"
+ done
+ einfo "UDF ${udfname}: compiling from ${src}"
+ ${CXX} \
+ ${CXXFLAGS} -I/usr/include/mysql \
+ ${LDFLAGS} -fPIC -shared -o "${udfoutpath}" $src \
+ || die "UDF ${udfname}: Failed to compile"
+}
+
+mysql-udf_src_install() {
+ local udfdir="${T}/udf/"
+ local udfname udfext udffile udfoutpath
+ udfname="${1}"
+ udfext=".so"
+ udffile="${udfname}${udfext}"
+ udfoutpath="${udfdir}/${udffile}"
+ insinto /usr/$(get_libdir)/mysql/plugins
+ doins "${udfoutpath}"
+}
+
+udf_done_intro=0
+mysql-udf_pkg_postinst() {
+ local udfname udffile udfext udffunc udfreturn
+ udfname="${1}"
+ udfext=".so"
+ udffile="${udfname}${udfext}"
+ udffunc="${2}"
+ udfreturn="${3}"
+ if [ ${udf_done_intro} -eq 0 ]; then
+ elog "To use the UDFs that were built:"
+ elog "Update your configuration to include 'plugin_dir=/usr/$(get_libdir)/mysql/plugins'"
+ elog "Issue the following commands as a user with FUNCTION privileges:"
+ udf_done_intro=1
+ fi
+ elog "CREATE FUNCTION ${udffunc} RETURNS ${udfreturn} SONAME '${udffile}'"
+}
+
+src_compile() {
+ perl-app_src_compile
+ if use udf; then
+ cd "${S}"/udf
+ mysql-udf_src_compile murmur_udf
+ mysql-udf_src_compile fnv_udf
+ fi
+}
+
+src_install() {
+ perl-module_src_install
+ if use udf; then
+ mysql-udf_src_install murmur_udf
+ mysql-udf_src_install fnv_udf
+ fi
+}
+
+pkg_postinst() {
+ if use udf; then
+ mysql-udf_pkg_postinst murmur_udf murmur_hash INTEGER
+ mysql-udf_pkg_postinst fnv_udf fnv_64 INTEGER
+ fi
+}
diff --git a/dev-db/maatkit/metadata.xml b/dev-db/maatkit/metadata.xml
new file mode 100644
index 000000000000..0e4bad3f0f4f
--- /dev/null
+++ b/dev-db/maatkit/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>idl0r@gentoo.org</email>
+ <name>Christian Ruppert</name>
+ </maintainer>
+ <longdescription>maatkit, formerly MySQL Toolkit, is a collection of command-line utilities that
+provide missing functionality for MySQL. Some of the tools implement lacking
+server functionality, such as online consistency checks for master/slave
+replication; others are client-side utilities such as a query profiler.</longdescription>
+ <use>
+ <flag name="udf">Build the MySQL UDFs shipped with maatkit, requires non-minimal MySQL</flag>
+ </use>
+ <upstream>
+ <remote-id type="google-code">maatkit</remote-id>
+ </upstream>
+</pkgmetadata>