summaryrefslogtreecommitdiff
path: root/dev-db/m17n-db/m17n-db-1.8.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-23 00:11:31 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-23 00:11:31 +0100
commitbff543bb632933380da922cbfc07c67157d72d42 (patch)
treedf2e5eebc3dbd8e29153ab3a869b3be8d9be9f19 /dev-db/m17n-db/m17n-db-1.8.0.ebuild
parent491d0101c89d81dec507f28215b3cb094800d600 (diff)
gentoo auto-resync : 23:06:2024 - 00:11:30
Diffstat (limited to 'dev-db/m17n-db/m17n-db-1.8.0.ebuild')
-rw-r--r--dev-db/m17n-db/m17n-db-1.8.0.ebuild20
1 files changed, 19 insertions, 1 deletions
diff --git a/dev-db/m17n-db/m17n-db-1.8.0.ebuild b/dev-db/m17n-db/m17n-db-1.8.0.ebuild
index 7342e3737171..7563ae96f68a 100644
--- a/dev-db/m17n-db/m17n-db-1.8.0.ebuild
+++ b/dev-db/m17n-db/m17n-db-1.8.0.ebuild
@@ -3,9 +3,13 @@
EAPI="8"
+GLIBC_PV="2.39"
+GLIBC_P="glibc-${GLIBC_PV}"
+
DESCRIPTION="Database for the m17n library"
HOMEPAGE="https://savannah.nongnu.org/projects/m17n https://git.savannah.nongnu.org/cgit/m17n/m17n-db.git"
-SRC_URI="mirror://nongnu/m17n/${P}.tar.gz"
+SRC_URI="mirror://nongnu/m17n/${P}.tar.gz
+ elibc_musl? ( mirror://gnu/glibc/${GLIBC_P}.tar.xz )"
LICENSE="LGPL-2.1"
SLOT="0"
@@ -15,6 +19,20 @@ IUSE=""
RDEPEND="virtual/libintl"
BDEPEND="sys-devel/gettext"
+CHARMAPS="${GLIBC_P}/localedata/charmaps"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+
+ if use elibc_musl; then
+ tar xf "${DISTDIR}"/${GLIBC_P}.tar.xz ${CHARMAPS} || die
+ fi
+}
+
+src_configure() {
+ econf $(usex elibc_musl "--with-charmaps=${WORKDIR}/${CHARMAPS}" "")
+}
+
src_install() {
default