summaryrefslogtreecommitdiff
path: root/dev-db/lib_mysqludf_json/lib_mysqludf_json-0.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-13 16:55:35 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-13 16:55:35 +0000
commit1dde4e5c4b92d849bf1abf0a48135b2a0644f7e1 (patch)
treec99a472cce74148d499f42ada873454b0e32a42d /dev-db/lib_mysqludf_json/lib_mysqludf_json-0.0.2.ebuild
parentda6a52f691ef980bab92d003d5df8f463c623af8 (diff)
gentoo resync : 13.03.2018
Diffstat (limited to 'dev-db/lib_mysqludf_json/lib_mysqludf_json-0.0.2.ebuild')
-rw-r--r--dev-db/lib_mysqludf_json/lib_mysqludf_json-0.0.2.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/dev-db/lib_mysqludf_json/lib_mysqludf_json-0.0.2.ebuild b/dev-db/lib_mysqludf_json/lib_mysqludf_json-0.0.2.ebuild
deleted file mode 100644
index 7e1fe812fcb9..000000000000
--- a/dev-db/lib_mysqludf_json/lib_mysqludf_json-0.0.2.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="MySQL UDFs to map relational data to the JSON format"
-HOMEPAGE="http://www.mysqludf.org/lib_mysqludf_json/"
-SRC_URI="http://www.mysqludf.org/${PN}/${PN}_${PV}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND=">=virtual/mysql-5.1"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}"
-
-# compile helper
-_compile() {
- local CC="$(tc-getCC)"
- echo "${CC} ${@}" && "${CC}" "${@}"
-}
-
-pkg_setup() {
- MYSQL_PLUGINDIR="$(mysql_config --plugindir)"
- MYSQL_INCLUDE="$(mysql_config --include)"
-}
-
-src_prepare() {
- # remove precompiled object
- rm -f -- ${PN}.so
-}
-
-src_compile() {
- _compile ${CFLAGS} -Wall -fPIC ${MYSQL_INCLUDE} \
- -shared ${LDFLAGS} -o ${PN}.so ${PN}.c
-}
-
-src_install() {
- exeinto "${MYSQL_PLUGINDIR}"
- doexe ${PN}.so
- dodoc ${PN}.sql
- dohtml ${PN}.html
-}
-
-pkg_postinst() {
- elog
- elog "Please have a look at the documentation, how to"
- elog "enable/disable the UDF functions of ${PN}."
- elog
- elog "The documentation is located here:"
- elog "/usr/share/doc/${PF}"
- elog
-}