summaryrefslogtreecommitdiff
path: root/dev-db/bucardo/bucardo-5.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-db/bucardo/bucardo-5.3.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-db/bucardo/bucardo-5.3.1.ebuild')
-rw-r--r--dev-db/bucardo/bucardo-5.3.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-db/bucardo/bucardo-5.3.1.ebuild b/dev-db/bucardo/bucardo-5.3.1.ebuild
new file mode 100644
index 000000000000..d28a6ecfc9d9
--- /dev/null
+++ b/dev-db/bucardo/bucardo-5.3.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+RESTRICT="test"
+
+inherit perl-module
+
+MY_PN="Bucardo"
+
+DESCRIPTION="An asynchronous PostgreSQL replication system"
+HOMEPAGE="http://bucardo.org/wiki/Bucardo"
+SRC_URI="http://bucardo.org/downloads/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+#IUSE="test" doesn't work without extra data
+IUSE=""
+
+DEPEND="dev-perl/DBIx-Safe
+ dev-perl/DBD-Pg"
+RDEPEND="dev-perl/DBIx-Safe"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_install() {
+ emake DESTDIR="${D}" INSTALL_BASE="${D}" install -j1
+ keepdir /var/run/bucardo
+}