summaryrefslogtreecommitdiff
path: root/dev-cpp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
commitb2be182d49eea46686b5cf2680d457df61e89dc4 (patch)
treec66442ced2011c5ca81c3114cc51041e314c6d33 /dev-cpp
parente23cdda4dbb0c83b9e682ab5e916085a35203da5 (diff)
gentoo resync : 30.06.2018
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/Manifest.gzbin9204 -> 9205 bytes
-rw-r--r--dev-cpp/websocketpp/Manifest3
-rw-r--r--dev-cpp/websocketpp/files/websocketpp-0.7.0-cmake-install.patch28
-rw-r--r--dev-cpp/websocketpp/websocketpp-0.7.0-r2.ebuild (renamed from dev-cpp/websocketpp/websocketpp-0.7.0-r1.ebuild)5
4 files changed, 33 insertions, 3 deletions
diff --git a/dev-cpp/Manifest.gz b/dev-cpp/Manifest.gz
index ce181bbd05ad..95697039e7ae 100644
--- a/dev-cpp/Manifest.gz
+++ b/dev-cpp/Manifest.gz
Binary files differ
diff --git a/dev-cpp/websocketpp/Manifest b/dev-cpp/websocketpp/Manifest
index 4cc6ba20aa08..d3dbfa650818 100644
--- a/dev-cpp/websocketpp/Manifest
+++ b/dev-cpp/websocketpp/Manifest
@@ -1,3 +1,4 @@
+AUX websocketpp-0.7.0-cmake-install.patch 970 BLAKE2B 2099c37b65d3f685f8b9745d92b481bb6a0434e6305e974c6f613ae44e70e1fa9d7bd577f875ef12228e506361409666099ce024578c5c524cc8fc5fbdef4b70 SHA512 c8b34b80890d8dc828d64e391e9541f7ebd6a18c79d3a5b91c72835745a11bafff110d04e8d75a2df2dba8b65ca1856050009a4eab3871cc2470066f9ad82f44
DIST websocketpp-0.7.0.tar.gz 682271 BLAKE2B 4da1fb076c2f533cdbdaa2cc0b0b45509216fcbc3b465f137905a34477aff0e93005f36d0257f314fd91b7de59e587e1b1df9af664a717b8dbf477b168025f26 SHA512 91a86d4f5120db3f474169bb146f865f82167b1e9eedabec8793b31005e4ce3d22083283bc1b9f9e37fa0da835addcb2b68260a27c753852c06b3b1bb2f3c12e
-EBUILD websocketpp-0.7.0-r1.ebuild 785 BLAKE2B a881cd969ee9426baa095431a63d67cafcd0cc37174e45e279d3f9a9e57c322f13e37a6008d922a47f252cf81dc83248c6eb4659ac87bd9994365c2227c15a87 SHA512 6d15ee7021ce643d7f1706f2198bd640b23ad0a9204cf0245ae551c7d810450d91e8c706d03822de98abfd00dd6be181ecba4292b35b7d09e6b550e3751d8377
+EBUILD websocketpp-0.7.0-r2.ebuild 787 BLAKE2B 93f68f1f064f4b31abe4adeb1be8014145469ba17262e7197ee3695207840442d6afb1362d0d1a4cebb456509ab554fd3bdb94fd2de0fdc605b98582c08fbd85 SHA512 8c79fbae1a1e2f943820e36be7e839983516acd206c101f2e0cf69612e42c166b131e1019d8fd27eac1f5689e729818df07ea1f0f2746d4098ffbc1eafe45299
MISC metadata.xml 419 BLAKE2B 11f113ce200752e1982b6f246f267e8029901c9dd6fa4dcdb131a28f62c3041792dc25b0ff449b20f755d9e9e9f1f4cfa23077f7648d8bfd17619b1887f44316 SHA512 92d8c85006a8857390b3bb83a9fcaa6e8a74a68eadc63018f6e70e2d4259332caaf549611a69baf44689557f05f1f7f7824d24bb9a5b582913b6580cc21608c0
diff --git a/dev-cpp/websocketpp/files/websocketpp-0.7.0-cmake-install.patch b/dev-cpp/websocketpp/files/websocketpp-0.7.0-cmake-install.patch
new file mode 100644
index 000000000000..4548c650759d
--- /dev/null
+++ b/dev-cpp/websocketpp/files/websocketpp-0.7.0-cmake-install.patch
@@ -0,0 +1,28 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index f60caa1..9ff2211 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -15,13 +15,20 @@ set (WEBSOCKETPP_VERSION ${WEBSOCKETPP_MAJOR_VERSION}.${WEBSOCKETPP_MINOR_VERSIO
+
+ set_property(GLOBAL PROPERTY USE_FOLDERS ON)
+
++get_property(LIB64 GLOBAL PROPERTY FIND_LIBRARY_USE_LIB64_PATHS)
++if ("${LIB64}" STREQUAL "TRUE")
++ set(LIBSUFFIX 64)
++else()
++ set(LIBSUFFIX "")
++endif()
++
+ set(INSTALL_INCLUDE_DIR include CACHE PATH "Installation directory for header files")
++set(LIB_INSTALL_DIR "lib${LIB_SUFFIX}")
+ if (WIN32 AND NOT CYGWIN)
+- set (DEF_INSTALL_CMAKE_DIR cmake)
++ set (INSTALL_CMAKE_DIR cmake)
+ else ()
+- set (DEF_INSTALL_CMAKE_DIR lib/cmake/websocketpp)
++ set (INSTALL_CMAKE_DIR ${LIB_INSTALL_DIR}/cmake/websocketpp)
+ endif ()
+-set (INSTALL_CMAKE_DIR ${DEF_INSTALL_CMAKE_DIR} CACHE PATH "Installation directory for CMake files")
+
+ # Make relative paths absolute (needed later on)
+ foreach (p INCLUDE CMAKE)
diff --git a/dev-cpp/websocketpp/websocketpp-0.7.0-r1.ebuild b/dev-cpp/websocketpp/websocketpp-0.7.0-r2.ebuild
index 5102455cf018..1f3730df214a 100644
--- a/dev-cpp/websocketpp/websocketpp-0.7.0-r1.ebuild
+++ b/dev-cpp/websocketpp/websocketpp-0.7.0-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -22,9 +22,10 @@ RDEPEND="${DEPEND}
# bug 630450
RESTRICT="test"
+PATCHES=( "${FILESDIR}/${P}-cmake-install.patch" )
+
src_configure() {
local mycmakeargs=(
- -DINSTALL_CMAKE_DIR="$(get_libdir)/cmake/${PN}"
-DENABLE_CPP11="$(usex !boost)"
-DBUILD_TESTS="$(usex test)"
)