summaryrefslogtreecommitdiff
path: root/dev-cpp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-16 12:22:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-16 12:22:56 +0100
commit2ca31eebd5b7496656193e0aa6ae39200d69a017 (patch)
tree6cf0c8f4ce90a3960c27acf45011134fb674dd62 /dev-cpp
parent3ad1879f00b279af69d6b9cd3ef97a2a7496d734 (diff)
gentoo auto-resync : 16:08:2024 - 12:22:56
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/Manifest.gzbin14620 -> 14615 bytes
-rw-r--r--dev-cpp/robin-hood-hashing/Manifest2
-rw-r--r--dev-cpp/robin-hood-hashing/files/robin-hood-hashing-include-cstdint.patch12
-rw-r--r--dev-cpp/robin-hood-hashing/robin-hood-hashing-3.11.5-r2.ebuild25
-rw-r--r--dev-cpp/yaml-cpp/Manifest3
-rw-r--r--dev-cpp/yaml-cpp/files/yaml-cpp-0.8.0-include-cstdint.patch33
-rw-r--r--dev-cpp/yaml-cpp/yaml-cpp-0.8.0.ebuild3
7 files changed, 76 insertions, 2 deletions
diff --git a/dev-cpp/Manifest.gz b/dev-cpp/Manifest.gz
index 0edc0d1f6e35..74a76913da59 100644
--- a/dev-cpp/Manifest.gz
+++ b/dev-cpp/Manifest.gz
Binary files differ
diff --git a/dev-cpp/robin-hood-hashing/Manifest b/dev-cpp/robin-hood-hashing/Manifest
index cb9a16c43216..59e4c3f2daa2 100644
--- a/dev-cpp/robin-hood-hashing/Manifest
+++ b/dev-cpp/robin-hood-hashing/Manifest
@@ -1,3 +1,5 @@
+AUX robin-hood-hashing-include-cstdint.patch 357 BLAKE2B debcd55902985d2f63e3a61c8774e14bf37849ef0b9f13513104c52351f499f77062d65f86211fb908569c43a38203977e4e250ecea96d7a29abb5d5cba4d416 SHA512 3599a407a8a27ce13b7e29b108599aef2af2cabb76ccbeb3e15f52b18b1a726c4bb71b95c8e67c6f1f38bfd090d780b113d82d8f38d84109cc56bf126fd9aa31
DIST robin-hood-hashing-3.11.5.tar.gz 177134 BLAKE2B b114c1d68ff2eae4cdb526e67def750a11056c2b5c400eab0870fda7c81dde5cf3bb168ea13ed3d34f2e57edffea5c58cb79ffb5328ecf839c723c71f54676d3 SHA512 5f73e089b1e8ec41a9bedded22bc64a789d3a3d04873a2ad9f8cc2970797a473b0f4d3436c2324b3ced85a0d983998a75b1dfaf2b7f3b77235b29806ff2fd489
EBUILD robin-hood-hashing-3.11.5-r1.ebuild 586 BLAKE2B d4daa6220cb51afe1bd31ceaf0eb0dc4c622016bbf642dd7099f2de583098d0477643e33e0d80d7c4cb8adfad490449a4a047aba305d843af754187c1b819927 SHA512 9caff99a89320cfd3ee7edb230829811c75e4573bbdeaf21ae892e29c935556924c3cb09c6cf7410b4483cb03f113ab333ea231549b059223e5deb49aca0e592
+EBUILD robin-hood-hashing-3.11.5-r2.ebuild 647 BLAKE2B 4352815fd7bce4ad76bef312bf872b310f1220a2186196abb660517fed52c528c271cd51f9ef831d521898c90c50c116a1d66a707bd87e63e767eb550860dd96 SHA512 c3390502d05f1ec67ab595a9994dbfcfa01f4f8c15016d1a70aaf26fe2020131271633b44d5d30d1d14864639c105876f1732db3d7cabbf4e000355d56f27cfa
MISC metadata.xml 432 BLAKE2B 13444b194ca3577792724af24a8cab24ccb905027261334a26115b099ee36f3cd5b5ecd4d1dc71f03ef33962ab3c068d627c7c85baa8e212007339c27c2a97f1 SHA512 0a915db4e5e7b6ef284e8c798fba99b351c725fc8e18158f4176d0a8211af2215058ad59124780c11cdd3bd9d7a2a2a084131aa92a9921e50aaca76c7c86a154
diff --git a/dev-cpp/robin-hood-hashing/files/robin-hood-hashing-include-cstdint.patch b/dev-cpp/robin-hood-hashing/files/robin-hood-hashing-include-cstdint.patch
new file mode 100644
index 000000000000..e5f10b7a0126
--- /dev/null
+++ b/dev-cpp/robin-hood-hashing/files/robin-hood-hashing-include-cstdint.patch
@@ -0,0 +1,12 @@
+diff --git a/src/include/robin_hood.h b/src/include/robin_hood.h
+index b4e0fbc..b83eaef 100644
+--- a/src/include/robin_hood.h
++++ b/src/include/robin_hood.h
+@@ -39,6 +39,7 @@
+ #define ROBIN_HOOD_VERSION_PATCH 5 // for backwards-compatible bug fixes
+
+ #include <algorithm>
++#include <cstdint>
+ #include <cstdlib>
+ #include <cstring>
+ #include <functional>
diff --git a/dev-cpp/robin-hood-hashing/robin-hood-hashing-3.11.5-r2.ebuild b/dev-cpp/robin-hood-hashing/robin-hood-hashing-3.11.5-r2.ebuild
new file mode 100644
index 000000000000..9e31bea3b72a
--- /dev/null
+++ b/dev-cpp/robin-hood-hashing/robin-hood-hashing-3.11.5-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+SRC_URI="https://github.com/martinus/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+DESCRIPTION="Fast & memory efficient hashtable based on robin hood hashing for C++11/14/17/20"
+HOMEPAGE="https://github.com/martinus/robin-hood-hashing"
+
+LICENSE="MIT"
+SLOT="0"
+
+PATCHES=( "${FILESDIR}/${PN}-include-cstdint.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DRH_STANDALONE_PROJECT=OFF
+ -DCMAKE_INSTALL_LIBDIR="${EPREFIX}/usr/share/"
+ )
+ cmake_src_configure
+}
diff --git a/dev-cpp/yaml-cpp/Manifest b/dev-cpp/yaml-cpp/Manifest
index d87a307a3d62..ac5c6276e45e 100644
--- a/dev-cpp/yaml-cpp/Manifest
+++ b/dev-cpp/yaml-cpp/Manifest
@@ -3,8 +3,9 @@ AUX yaml-cpp-0.7.0-gtest.patch 1081 BLAKE2B 7fe415662ce9eb205f6f1c42df9885ae5817
AUX yaml-cpp-0.7.0-install-paths.patch 1062 BLAKE2B c76f9f34e7f20954a2f2f0582f5d124ec22af2c91dccc19b4c7891b19d14bc2aff7d61f93b20a606c58397c70f9db2f35f10c6645869253a5bedd50d9e65eaa1 SHA512 9d14416fdb8111027324ffeae3856590348f9497444ecae7a2091d3211e17fe61fdd66932b98c119cf54551c551aa8f6a698a2c5a97cb559cf6e3a54f25e07cb
AUX yaml-cpp-0.8.0-gcc13.patch 2242 BLAKE2B 8b5b99e86a578310dd020237a82150dd0ae47dc009cff2f423ec6248c77635384c6e4ff0620a446858ec12223ea3148a006a76fd9c5a02c28cf29c0969b19dfd SHA512 429ca92104b6203695970e7bc79ed452c0dd6a02b98beb2e640a89184d10f1daedf10a5f7697942036317225c52a054c0916bfe1c54635b34b83721f72a31f6d
AUX yaml-cpp-0.8.0-gtest.patch 954 BLAKE2B 916365624688a62d2fa1f5dcbe62e65c872439efd8172a9898457797ce857003c31d8de082fe87ee9a47027f4021bc87ded88e7d4e40ed87e2da2a2333cc6d62 SHA512 781451e4477c22f059bb22b59b253bc2c2d4c0668bb00b44867d79a6d0e87f95abcfa11d35bcbf0e7aacc94b9185dfbef814018d7a58df00d93cd13ca0df8edc
+AUX yaml-cpp-0.8.0-include-cstdint.patch 1090 BLAKE2B 0415488b047454dfbbf962b6e1f135c277e7c4b1cce30b76045c611d3cee9dcf6f701c8ff290ff3943442dd1d3c7ec8d5547328a91dbced7d93530d4dcb9703f SHA512 1e376b6ba5b4f5673271bb0790768ca8512efe44d821940c7bc58539d08f118bc30ebaa64a137bf7ba77987f6c5596706dcf99a9b4a58199aa0e4f7aa2969b52
DIST yaml-cpp-0.7.0.tar.gz 1033237 BLAKE2B 69a11a8503ad607aa0d54912a5e53d305a643fe2d36dd86fa96832e3d4930b39a85318dc130e438210a9ca60357f3aa9aa6cd0f2b6bc45728b648c545a437368 SHA512 2de0f0ec8f003cd3c498d571cda7a796bf220517bad2dc02cba70c522dddde398f33cf1ad20da251adaacb2a07b77844111f297e99d45a7c46ebc01706bbafb5
DIST yaml-cpp-0.8.0.gh.tar.gz 1017151 BLAKE2B 5fd3eaec06bc04215afd2aa14ae8cd35f829f700f104931a51dbd8bb22e4e87f5cd5f2f975d3a2f464226d7165d3d106aa17bc7eab8a812c2545d2212011cf11 SHA512 aae9d618f906117d620d63173e95572c738db518f4ff1901a06de2117d8deeb8045f554102ca0ba4735ac0c4d060153a938ef78da3e0da3406d27b8298e5f38e
EBUILD yaml-cpp-0.7.0-r2.ebuild 857 BLAKE2B 63735ee4c253e6b04cf7c2c9b0725cf4aad80564eca30ca2e80360e8fa4d1263d95af7260cfa49c182d1109b13dd1ef5e754d1e6967f6414d9745ecf683b71b9 SHA512 7308409215a0e874fe4d2a2a6b8a8ccbfba8b4617a3852d50d40ca70cd2394fde8c1b8e1224136018aa043aecf3dbb6bc515e1ac90517c448c904a6315944249
-EBUILD yaml-cpp-0.8.0.ebuild 834 BLAKE2B 79015081abc63012a566c0a9b312d1cf0730f446b1ccd91c46af38f39fbfab8fc966d6ebe7f105acd572afa4cf79dc6f34cdcf7f67e7568a228395115bc16ec6 SHA512 a3b1e11b3ce2dd532a8951fa00b6991d069fbbe02df23b71d9c4dc8b82b20616901fdcc92a52d50ffb99536a59c957e924a197e391948212df9ee137c95c5ef1
+EBUILD yaml-cpp-0.8.0.ebuild 886 BLAKE2B 3201a330fa6b5de80fbc96216b38ff4f52a38ba64ca652d0c002a750c8f343d6b518d19b8f621a56c5d8a95378ebb78306050a7da5072030110d7c52feb66755 SHA512 f9f2ae48d5fc6f5a2338a1582999e7db9c9cb1a2cb22880db1b5f845e1ca36e29a17353732f0fa64057d773e211a53215097d905be947998209066033d422e74
MISC metadata.xml 484 BLAKE2B e973aef681bed7de47725bab49d2acfe809ad73c97eea709bec9d5bb9d720f89bc222ff77f09b90780b2a14d6a094f9ddd24a4f15d6ad88b94060d240c5836d8 SHA512 612604d3b0c2edd157c4a55ae22d92e174cdcbc17532de7f2888b9579b4b028da2214e6d756864dfffdeca129f32e5db2241308d326c6ff21044f48bf2d87d73
diff --git a/dev-cpp/yaml-cpp/files/yaml-cpp-0.8.0-include-cstdint.patch b/dev-cpp/yaml-cpp/files/yaml-cpp-0.8.0-include-cstdint.patch
new file mode 100644
index 000000000000..d017b43fa440
--- /dev/null
+++ b/dev-cpp/yaml-cpp/files/yaml-cpp-0.8.0-include-cstdint.patch
@@ -0,0 +1,33 @@
+https://github.com/jbeder/yaml-cpp/pull/1310
+
+From: Christopher Fore <csfore@posteo.net>
+Date: Wed, 14 Aug 2024 21:02:32 -0400
+Subject: [PATCH] emitterutils: Explicitly include <cstdint>
+
+GCC 15 will no longer include it by default, resulting in build
+failures in projects that do not explicitly include it.
+
+Error:
+src/emitterutils.cpp:221:11: error: 'uint16_t' was not declared in this scope
+ 221 | std::pair<uint16_t, uint16_t> EncodeUTF16SurrogatePair(int codePoint) {
+ | ^~~~~~~~
+src/emitterutils.cpp:13:1: note: 'uint16_t' is defined in header '<cstdint>';
+this is probably fixable by adding '#include <cstdint>'
+ 12 | #include "yaml-cpp/null.h"
+ +++ |+#include <cstdint>
+ 13 | #include "yaml-cpp/ostream_wrapper.h"
+
+Tests pass.
+
+Closes: #1307
+See-also: https://gcc.gnu.org/pipermail/gcc-cvs/2024-August/407124.html
+See-also: https://bugs.gentoo.org/937412
+Signed-off-by: Christopher Fore <csfore@posteo.net>
+--- a/src/emitterutils.cpp
++++ b/src/emitterutils.cpp
+@@ -1,4 +1,5 @@
+ #include <algorithm>
++#include <cstdint>
+ #include <iomanip>
+ #include <sstream>
+
diff --git a/dev-cpp/yaml-cpp/yaml-cpp-0.8.0.ebuild b/dev-cpp/yaml-cpp/yaml-cpp-0.8.0.ebuild
index dc3a8a58c33c..5691f9d3a803 100644
--- a/dev-cpp/yaml-cpp/yaml-cpp-0.8.0.ebuild
+++ b/dev-cpp/yaml-cpp/yaml-cpp-0.8.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -22,6 +22,7 @@ DEPEND="
PATCHES=(
"${FILESDIR}/yaml-cpp-0.8.0-gtest.patch"
"${FILESDIR}/yaml-cpp-0.8.0-gcc13.patch"
+ "${FILESDIR}/yaml-cpp-0.8.0-include-cstdint.patch"
)
src_configure() {