summaryrefslogtreecommitdiff
path: root/dev-cpp/websocketpp/websocketpp-0.8.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-21 18:59:32 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-21 18:59:32 +0100
commit520a5b56dff7c24c9d42eafec142cb78b44f8e3e (patch)
treef562f705600dbd2292e97c0b4145787c2a8d1f97 /dev-cpp/websocketpp/websocketpp-0.8.1.ebuild
parent3811bc3072bf19e2be351d2c63f81532945c0f21 (diff)
gentoo resync : 21.07.2018
Diffstat (limited to 'dev-cpp/websocketpp/websocketpp-0.8.1.ebuild')
-rw-r--r--dev-cpp/websocketpp/websocketpp-0.8.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-cpp/websocketpp/websocketpp-0.8.1.ebuild b/dev-cpp/websocketpp/websocketpp-0.8.1.ebuild
new file mode 100644
index 000000000000..0818e872e796
--- /dev/null
+++ b/dev-cpp/websocketpp/websocketpp-0.8.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="C++/Boost Asio based websocket client/server library"
+HOMEPAGE="http://www.zaphoyd.com/websocketpp"
+SRC_URI="https://github.com/zaphoyd/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc64 ~x86"
+LICENSE="BSD"
+SLOT="0"
+IUSE="boost examples test"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ boost? ( dev-libs/boost )
+"
+
+# bug 630450
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}/${PN}-0.7.0-cmake-install.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_CPP11="$(usex !boost)"
+ -DBUILD_TESTS="$(usex test)"
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ use examples && DOCS=( examples/ )
+ cmake-utils_src_install
+}