summaryrefslogtreecommitdiff
path: root/dev-cpp/waylandpp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-28 02:49:59 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-28 02:49:59 +0000
commite53aa6b4fbe5a0c6db75d893829f7a6a37a14180 (patch)
treedd095d36490410a724fd271fcdf08c31a5336edd /dev-cpp/waylandpp
parentc5ee568457ac776b65b71fa444e0dd47535bc44a (diff)
gentoo auto-resync : 28:01:2023 - 02:49:59
Diffstat (limited to 'dev-cpp/waylandpp')
-rw-r--r--dev-cpp/waylandpp/Manifest2
-rw-r--r--dev-cpp/waylandpp/files/waylandpp-1.0.0-gcc-13.patch51
-rw-r--r--dev-cpp/waylandpp/waylandpp-1.0.0-r1.ebuild45
3 files changed, 98 insertions, 0 deletions
diff --git a/dev-cpp/waylandpp/Manifest b/dev-cpp/waylandpp/Manifest
index bdec871e4d13..0bf7bcff5629 100644
--- a/dev-cpp/waylandpp/Manifest
+++ b/dev-cpp/waylandpp/Manifest
@@ -1,4 +1,6 @@
+AUX waylandpp-1.0.0-gcc-13.patch 1838 BLAKE2B 870c9f81b0b400fdee8901780c90fd5cac3385a864b69cc0bd4823154045413b9aeaf3088f176265102cd3f5a9124f026de7c9521d284e8f82b5b759305db8cb SHA512 07cf5df91dfe12607fa26dbaf9862fa6e5100113a92dd6e447743996f9794e2190160527b00eb04ff1fe5e698dbc4a60478db4366b2eb3c2c7e7799116e816c3
DIST waylandpp-1.0.0.tar.gz 203510 BLAKE2B 939262f61051fb242e779fa4817b262af2de6acef50b53a55e8565e6305e84fbf297adad02d27342a39e2a1be920443cc6dd50711e2c584b3322fa1e90a7051c SHA512 64b59d073a0593ecf442362eb63ec0a9dfeaa1ad1d56b5955cb0c159fd01dc45e012b926811c6ca0dc12d4bb2e640eabc2e778ab7d28de2098eb694d26f01039
+EBUILD waylandpp-1.0.0-r1.ebuild 832 BLAKE2B e6ed3ff19e12241378c937f738fb386f617dde280aeb20d303d12de54e830c7274013eebb508a3e2b6cc272c463d6d97a8fa69be99b9b53ceeb6b99511daa667 SHA512 47e2d1e025d81fbaf7ca85a7953d9d31c5120004d8a006de5c90c938c9abf87693dc6e8a7c1b08c0dcfa7facc28548cebdd637b678e5c458274b432286cf3710
EBUILD waylandpp-1.0.0.ebuild 776 BLAKE2B 761fc638851faecfaa5e1f5860dfa530943665ef32de5df56ddfe434030df968619887301446917872f9384a11af23fe19461a2fa65f7ea2a81769255859cd59 SHA512 ab23f423bd91e65f0c7406842c5ccd19f674ebcd509e9277bceba0d6fd32745fd50176a274539acf3d7239f7e66f814d524de1c3a6c968d99d2f51871fc17bf8
EBUILD waylandpp-9999.ebuild 772 BLAKE2B b51d2c384a30ed30120215fcc1980fdf22e32e78f5f12c701d95b8469fa88ae00922193ad9f7b987eb682d1a742379e3d38efe95ca0ec7e7ef47b77649a062ed SHA512 50a7bc3d744b1efdec9e5539d44f2a992b7d549595d3e2a5c30af98ef968ce529b26fcb41e5962abd91264a8b59455503c7bec01cb6a11380a5d081ae4b9f4e4
MISC metadata.xml 402 BLAKE2B bcf8f38c837191d5b398b7679d82bca3039b7b407db3b89d2e0bdc7f15ee809484e12c6a2f60688e63bf8038954d01f1bbc30a8584d250918e28883d3673ec9f SHA512 53a66bb7c703917687d2acb7b95ac10f092669b46e9ecf5861e50141e89a4994eaeab6c6d4b6f7e4c0cd700555be5ef1b6137fd5a610530cf5d678bbc1bd346c
diff --git a/dev-cpp/waylandpp/files/waylandpp-1.0.0-gcc-13.patch b/dev-cpp/waylandpp/files/waylandpp-1.0.0-gcc-13.patch
new file mode 100644
index 000000000000..314b1aa5fb80
--- /dev/null
+++ b/dev-cpp/waylandpp/files/waylandpp-1.0.0-gcc-13.patch
@@ -0,0 +1,51 @@
+https://github.com/NilsBrause/waylandpp/pull/71
+
+From 3c441910aa25f57df2a4db55f75f5d99cea86620 Mon Sep 17 00:00:00 2001
+From: Sergei Trofimovich <slyich@gmail.com>
+Date: Sun, 8 Jan 2023 18:24:53 +0000
+Subject: [PATCH] add missing <cstdint> include
+
+Upcoming `gcc-13` made `<string>` leaner and does not include `<cstdint>`
+implicitly anymore. As a result build fails without the change as:
+
+ [ 2%] Building CXX object CMakeFiles/wayland-scanner++.dir/scanner/scanner.cpp.o
+ scanner/scanner.cpp:378:3: error: 'uint32_t' does not name a type
+ 378 | uint32_t width = 0;
+ | ^~~~~~~~
+--- a/include/wayland-client.hpp
++++ b/include/wayland-client.hpp
+@@ -29,6 +29,7 @@
+ /** \file */
+
+ #include <atomic>
++#include <cstdint>
+ #include <functional>
+ #include <memory>
+ #include <string>
+--- a/scanner/scanner.cpp
++++ b/scanner/scanner.cpp
+@@ -23,6 +23,7 @@
+ #include <vector>
+ #include <cctype>
+ #include <cmath>
++#include <cstdint>
+ #include <stdexcept>
+
+ #include "pugixml.hpp"
+@@ -1106,6 +1107,7 @@ int main(int argc, char *argv[])
+ wayland_hpp << "#pragma once" << std::endl
+ << std::endl
+ << "#include <array>" << std::endl
++ << "#include <cstdint>" << std::endl
+ << "#include <functional>" << std::endl
+ << "#include <memory>" << std::endl
+ << "#include <string>" << std::endl
+@@ -1125,6 +1127,7 @@ int main(int argc, char *argv[])
+ wayland_server_hpp << "#pragma once" << std::endl
+ << std::endl
+ << "#include <array>" << std::endl
++ << "#include <cstdint>" << std::endl
+ << "#include <functional>" << std::endl
+ << "#include <memory>" << std::endl
+ << "#include <string>" << std::endl
+
diff --git a/dev-cpp/waylandpp/waylandpp-1.0.0-r1.ebuild b/dev-cpp/waylandpp/waylandpp-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..739434a74de6
--- /dev/null
+++ b/dev-cpp/waylandpp/waylandpp-1.0.0-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Wayland C++ bindings"
+HOMEPAGE="https://github.com/NilsBrause/waylandpp"
+
+LICENSE="MIT"
+IUSE="doc"
+SLOT="0/$(ver_cut 1-2)"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/NilsBrause/waylandpp.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/NilsBrause/waylandpp/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+fi
+
+RDEPEND="
+ >=dev-libs/wayland-1.11.0
+ media-libs/mesa[wayland]
+ >=dev-libs/pugixml-1.9-r1
+"
+DEPEND="${RDEPEND}
+ doc? (
+ app-doc/doxygen
+ media-gfx/graphviz
+ )
+ "
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.0-gcc-13.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_DOCUMENTATION=$(usex doc)
+ )
+
+ cmake_src_configure
+}