summaryrefslogtreecommitdiff
path: root/dev-cpp/tbb/tbb-2021.11.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-29 00:57:18 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-29 00:57:18 +0000
commiteecd75a62239257eb2235bfe8697c73887a9a080 (patch)
tree8c01b16cb32e1a22ad5b8efe32d843c96cfa2ff2 /dev-cpp/tbb/tbb-2021.11.0.ebuild
parent7b97d94d4769a556456398d66819200655c4d76c (diff)
gentoo auto-resync : 29:01:2024 - 00:57:18
Diffstat (limited to 'dev-cpp/tbb/tbb-2021.11.0.ebuild')
-rw-r--r--dev-cpp/tbb/tbb-2021.11.0.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/dev-cpp/tbb/tbb-2021.11.0.ebuild b/dev-cpp/tbb/tbb-2021.11.0.ebuild
index 2e11233b7583..3ac69c080835 100644
--- a/dev-cpp/tbb/tbb-2021.11.0.ebuild
+++ b/dev-cpp/tbb/tbb-2021.11.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit cmake-multilib
+inherit cmake-multilib flag-o-matic
DESCRIPTION="High level abstract threading library"
HOMEPAGE="https://github.com/oneapi-src/oneTBB"
@@ -35,6 +35,9 @@ src_prepare() {
}
src_configure() {
+ # Workaround for bug #912210
+ append-ldflags $(test-flags-CCLD -Wl,--undefined-version)
+
local mycmakeargs=(
-DTBB_TEST=$(usex test)
-DTBB_ENABLE_IPO=OFF