summaryrefslogtreecommitdiff
path: root/dev-cpp/tbb/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-cpp/tbb/files
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-cpp/tbb/files')
-rw-r--r--dev-cpp/tbb/files/tbb-2017.20161128-build.patch187
-rw-r--r--dev-cpp/tbb/files/tbb-4.0.297-underlinking.patch20
-rw-r--r--dev-cpp/tbb/files/tbb-4.3.20150611-build.patch185
-rw-r--r--dev-cpp/tbb/files/tbb-4.4.20160803-build.patch187
-rw-r--r--dev-cpp/tbb/files/tbb-4.4.20160803-underlinking.patch15
5 files changed, 0 insertions, 594 deletions
diff --git a/dev-cpp/tbb/files/tbb-2017.20161128-build.patch b/dev-cpp/tbb/files/tbb-2017.20161128-build.patch
deleted file mode 100644
index e952bfbc434e..000000000000
--- a/dev-cpp/tbb/files/tbb-2017.20161128-build.patch
+++ /dev/null
@@ -1,187 +0,0 @@
---- a/build/FreeBSD.gcc.inc
-+++ b/build/FreeBSD.gcc.inc
-@@ -28,8 +28,8 @@ WARNING_KEY = -Wall
- DYLIB_KEY = -shared
- WARNING_SUPPRESS = -Wno-parentheses
-
--CPLUS = g++
--CONLY = gcc
-+CPLUS = $(CXX)
-+CONLY = $(CC)
- LIB_LINK_FLAGS = -shared
- LIBS = -lpthread
- C_FLAGS = $(CPLUS_FLAGS)
-@@ -42,7 +42,7 @@ ifneq (,$(shell gcc -dumpversion | egrep "^([6-9])"))
- endif
-
- ifeq ($(cfg), release)
-- CPLUS_FLAGS = -g -O2 -DUSE_PTHREAD
-+ CPLUS_FLAGS = -g -DUSE_PTHREAD
- endif
- ifeq ($(cfg), debug)
- CPLUS_FLAGS = -DTBB_USE_DEBUG -g -O0 -DUSE_PTHREAD
-@@ -59,22 +59,12 @@ ifeq (ia64,$(arch))
- CPLUS_FLAGS += $(PIC_KEY)
- endif
-
--ifeq (intel64,$(arch))
-- CPLUS_FLAGS += -m64
-- LIB_LINK_FLAGS += -m64
--endif
--
--ifeq (ia32,$(arch))
-- CPLUS_FLAGS += -m32
-- LIB_LINK_FLAGS += -m32
--endif
--
- #------------------------------------------------------------------------------
- # Setting assembler data.
- #------------------------------------------------------------------------------
- ASSEMBLY_SOURCE=$(arch)-gas
- ifeq (ia64,$(arch))
-- ASM=as
-+ ASM=$(AS)
- TBB_ASM.OBJ = atomic_support.o lock_byte.o log2.o pause.o
- MALLOC_ASM.OBJ = atomic_support.o lock_byte.o pause.o
- endif
---- a/build/linux.clang.inc
-+++ b/build/linux.clang.inc
-@@ -31,15 +31,15 @@ DYLIB_KEY = -shared
- EXPORT_KEY = -Wl,--version-script,
- LIBDL = -ldl
-
--CPLUS = clang++
--CONLY = clang
-+CPLUS := $(CXX)
-+CONLY := $(CC)
- LIB_LINK_FLAGS = $(DYLIB_KEY) -Wl,-soname=$(BUILDING_LIBRARY)
- LIBS += -lpthread -lrt
- LINK_FLAGS = -Wl,-rpath-link=. -rdynamic
- C_FLAGS = $(CPLUS_FLAGS)
-
- ifeq ($(cfg), release)
-- CPLUS_FLAGS = $(ITT_NOTIFY) -g -O2 -DUSE_PTHREAD
-+ CPLUS_FLAGS = $(ITT_NOTIFY) -g -DUSE_PTHREAD
- endif
- ifeq ($(cfg), debug)
- CPLUS_FLAGS = -DTBB_USE_DEBUG $(ITT_NOTIFY) -g -O0 -DUSE_PTHREAD
-@@ -60,24 +60,10 @@ MALLOC_ASM.OBJ=
-
- ifeq (intel64,$(arch))
- ITT_NOTIFY = -DDO_ITT_NOTIFY
-- CPLUS_FLAGS += -m64
-- LIB_LINK_FLAGS += -m64
- endif
-
- ifeq (ia32,$(arch))
- ITT_NOTIFY = -DDO_ITT_NOTIFY
-- CPLUS_FLAGS += -m32 -march=pentium4
-- LIB_LINK_FLAGS += -m32
--endif
--
--ifeq (ppc64,$(arch))
-- CPLUS_FLAGS += -m64
-- LIB_LINK_FLAGS += -m64
--endif
--
--ifeq (ppc32,$(arch))
-- CPLUS_FLAGS += -m32
-- LIB_LINK_FLAGS += -m32
- endif
-
- ifeq (bg,$(arch))
-@@ -89,12 +75,6 @@ endif
- # Setting assembler data.
- #------------------------------------------------------------------------------
- ASM = as
--ifeq (intel64,$(arch))
-- ASM_FLAGS += --64
--endif
--ifeq (ia32,$(arch))
-- ASM_FLAGS += --32
--endif
- ifeq ($(cfg),debug)
- ASM_FLAGS += -g
- endif
---- a/build/linux.gcc.inc
-+++ b/build/linux.gcc.inc
-@@ -32,12 +32,12 @@ DYLIB_KEY = -shared
- EXPORT_KEY = -Wl,--version-script,
- LIBDL = -ldl
-
--CPLUS = g++
--CONLY = gcc
-+CPLUS := $(CXX)
-+CONLY := $(CC)
- LIB_LINK_FLAGS = $(DYLIB_KEY) -Wl,-soname=$(BUILDING_LIBRARY)
- LIBS += -lpthread -lrt
- LINK_FLAGS = -Wl,-rpath-link=. -rdynamic
--C_FLAGS = $(CPLUS_FLAGS)
-+C_FLAGS := $(CPLUS_FLAGS)
-
- # gcc 4.2 and higher support OpenMP
- ifneq (,$(shell gcc -dumpversion | egrep "^(4\.[2-9]|[5-9])"))
-@@ -68,7 +68,7 @@ ifneq (,$(shell gcc -dumpversion | egrep "^([6-9])"))
- endif
-
- ifeq ($(cfg), release)
-- CPLUS_FLAGS = $(ITT_NOTIFY) -g -O2 -DUSE_PTHREAD
-+ CPLUS_FLAGS = $(ITT_NOTIFY) -g -DUSE_PTHREAD
- endif
- ifeq ($(cfg), debug)
- CPLUS_FLAGS = -DTBB_USE_DEBUG $(ITT_NOTIFY) -g -O0 -DUSE_PTHREAD
-@@ -84,24 +84,12 @@ endif
-
- ifeq (intel64,$(arch))
- ITT_NOTIFY = -DDO_ITT_NOTIFY
-- CPLUS_FLAGS += -m64 $(RTM_KEY)
-- LIB_LINK_FLAGS += -m64
-+ CPLUS_FLAGS += $(RTM_KEY)
- endif
-
- ifeq (ia32,$(arch))
- ITT_NOTIFY = -DDO_ITT_NOTIFY
-- CPLUS_FLAGS += -m32 -march=pentium4 $(RTM_KEY)
-- LIB_LINK_FLAGS += -m32
--endif
--
--ifeq (ppc64,$(arch))
-- CPLUS_FLAGS += -m64
-- LIB_LINK_FLAGS += -m64
--endif
--
--ifeq (ppc32,$(arch))
-- CPLUS_FLAGS += -m32
-- LIB_LINK_FLAGS += -m32
-+ CPLUS_FLAGS += $(RTM_KEY)
- endif
-
- ifeq (bg,$(arch))
-@@ -109,12 +97,6 @@ ifeq (bg,$(arch))
- CONLY = $(firstword $(notdir $(shell which powerpc{64,32,}-bg{z..a}-linux-gcc 2>/dev/null)))
- endif
-
--# for some gcc versions on Solaris, -m64 may imply V9, but perhaps not everywhere (TODO: verify)
--ifeq (sparc,$(arch))
-- CPLUS_FLAGS += -mcpu=v9 -m64
-- LIB_LINK_FLAGS += -mcpu=v9 -m64
--endif
--
- # automatically generate "IT" instructions when compiling for Thumb ISA
- ifeq (armv7,$(arch))
- CPLUS_FLAGS += -Wa,-mimplicit-it=thumb
-@@ -123,13 +105,7 @@ endif
- #------------------------------------------------------------------------------
- # Setting assembler data.
- #------------------------------------------------------------------------------
--ASM = as
--ifeq (intel64,$(arch))
-- ASM_FLAGS += --64
--endif
--ifeq (ia32,$(arch))
-- ASM_FLAGS += --32
--endif
-+ASM := $(AS)
- ifeq ($(cfg),debug)
- ASM_FLAGS += -g
- endif
diff --git a/dev-cpp/tbb/files/tbb-4.0.297-underlinking.patch b/dev-cpp/tbb/files/tbb-4.0.297-underlinking.patch
deleted file mode 100644
index ed318cab8386..000000000000
--- a/dev-cpp/tbb/files/tbb-4.0.297-underlinking.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-From: Julian Ospald <hasufell@gentoo.org>
-Date: Thu May 31 21:37:47 UTC 2012
-Subject: build system
-
-fix underlinking in test phase
-wrt https://bugs.gentoo.org/show_bug.cgi?id=418447
-
---- a/build/Makefile.test
-+++ b/build/Makefile.test
-@@ -48,8 +48,8 @@
- USE_PROXY_FLAG = $(DEFINE_KEY)HARNESS_USE_PROXY
- CPLUS_FLAGS += $(USE_PROXY_FLAG)
- LINK_TBB.LIB = $(PROXY.LIB)
-- LIBS += $(LIBDL)
--endif
-+endif
-+LIBS += $(LIBDL)
-
- include $(tbb_root)/build/common_rules.inc
-
diff --git a/dev-cpp/tbb/files/tbb-4.3.20150611-build.patch b/dev-cpp/tbb/files/tbb-4.3.20150611-build.patch
deleted file mode 100644
index 8f806989e443..000000000000
--- a/dev-cpp/tbb/files/tbb-4.3.20150611-build.patch
+++ /dev/null
@@ -1,185 +0,0 @@
---- a/build/FreeBSD.gcc.inc
-+++ b/build/FreeBSD.gcc.inc
-@@ -28,14 +28,14 @@ WARNING_KEY = -Wall
- DYLIB_KEY = -shared
- WARNING_SUPPRESS = -Wno-parentheses
-
--CPLUS = g++
--CONLY = gcc
-+CPLUS = $(CXX)
-+CONLY = $(CC)
- LIB_LINK_FLAGS = -shared
- LIBS = -lpthread
- C_FLAGS = $(CPLUS_FLAGS)
-
- ifeq ($(cfg), release)
-- CPLUS_FLAGS = -g -O2 -DUSE_PTHREAD
-+ CPLUS_FLAGS = -g -DUSE_PTHREAD
- endif
- ifeq ($(cfg), debug)
- CPLUS_FLAGS = -DTBB_USE_DEBUG -g -O0 -DUSE_PTHREAD
-@@ -52,22 +52,12 @@ ifeq (ia64,$(arch))
- CPLUS_FLAGS += $(PIC_KEY)
- endif
-
--ifeq (intel64,$(arch))
-- CPLUS_FLAGS += -m64
-- LIB_LINK_FLAGS += -m64
--endif
--
--ifeq (ia32,$(arch))
-- CPLUS_FLAGS += -m32
-- LIB_LINK_FLAGS += -m32
--endif
--
- #------------------------------------------------------------------------------
- # Setting assembler data.
- #------------------------------------------------------------------------------
- ASSEMBLY_SOURCE=$(arch)-gas
- ifeq (ia64,$(arch))
-- ASM=as
-+ ASM=$(AS)
- TBB_ASM.OBJ = atomic_support.o lock_byte.o log2.o pause.o
- MALLOC_ASM.OBJ = atomic_support.o lock_byte.o pause.o
- endif
---- a/build/linux.clang.inc
-+++ b/build/linux.clang.inc
-@@ -31,15 +31,15 @@ DYLIB_KEY = -shared
- EXPORT_KEY = -Wl,--version-script,
- LIBDL = -ldl
-
--CPLUS = clang++
--CONLY = clang
-+CPLUS := $(CXX)
-+CONLY := $(CC)
- LIB_LINK_FLAGS = $(DYLIB_KEY) -Wl,-soname=$(BUILDING_LIBRARY)
- LIBS += -lpthread -lrt
- LINK_FLAGS = -Wl,-rpath-link=. -rdynamic
- C_FLAGS = $(CPLUS_FLAGS)
-
- ifeq ($(cfg), release)
-- CPLUS_FLAGS = $(ITT_NOTIFY) -g -O2 -DUSE_PTHREAD
-+ CPLUS_FLAGS = $(ITT_NOTIFY) -g -DUSE_PTHREAD
- endif
- ifeq ($(cfg), debug)
- CPLUS_FLAGS = -DTBB_USE_DEBUG $(ITT_NOTIFY) -g -O0 -DUSE_PTHREAD
-@@ -61,24 +61,10 @@ MALLOC_ASM.OBJ=
-
- ifeq (intel64,$(arch))
- ITT_NOTIFY = -DDO_ITT_NOTIFY
-- CPLUS_FLAGS += -m64
-- LIB_LINK_FLAGS += -m64
- endif
-
- ifeq (ia32,$(arch))
- ITT_NOTIFY = -DDO_ITT_NOTIFY
-- CPLUS_FLAGS += -m32 -march=pentium4
-- LIB_LINK_FLAGS += -m32
--endif
--
--ifeq (ppc64,$(arch))
-- CPLUS_FLAGS += -m64
-- LIB_LINK_FLAGS += -m64
--endif
--
--ifeq (ppc32,$(arch))
-- CPLUS_FLAGS += -m32
-- LIB_LINK_FLAGS += -m32
- endif
-
- ifeq (bg,$(arch))
-@@ -90,12 +76,6 @@ endif
- # Setting assembler data.
- #------------------------------------------------------------------------------
- ASM = as
--ifeq (intel64,$(arch))
-- ASM_FLAGS += --64
--endif
--ifeq (ia32,$(arch))
-- ASM_FLAGS += --32
--endif
- ifeq ($(cfg),debug)
- ASM_FLAGS += -g
- endif
---- a/build/linux.gcc.inc
-+++ b/build/linux.gcc.inc
-@@ -32,12 +32,12 @@ DYLIB_KEY = -shared
- EXPORT_KEY = -Wl,--version-script,
- LIBDL = -ldl
-
--CPLUS = g++
--CONLY = gcc
-+CPLUS := $(CXX)
-+CONLY := $(CC)
- LIB_LINK_FLAGS = $(DYLIB_KEY) -Wl,-soname=$(BUILDING_LIBRARY)
- LIBS += -lpthread -lrt
- LINK_FLAGS = -Wl,-rpath-link=. -rdynamic
--C_FLAGS = $(CPLUS_FLAGS)
-+C_FLAGS := $(CPLUS_FLAGS)
- # gcc 4.4 and higher support -std=c++0x
- ifneq (,$(shell gcc -dumpversion | egrep "^(4\.[4-9]|[5-9])"))
- CPP11_FLAGS = -std=c++0x -D_TBB_CPP0X
-@@ -54,7 +54,7 @@ ifneq (,$(shell gcc -dumpversion | egrep "^4\.[8-9]"))
- endif
-
- ifeq ($(cfg), release)
-- CPLUS_FLAGS = $(ITT_NOTIFY) -g -O2 -DUSE_PTHREAD
-+ CPLUS_FLAGS = $(ITT_NOTIFY) -g -DUSE_PTHREAD
- endif
- ifeq ($(cfg), debug)
- CPLUS_FLAGS = -DTBB_USE_DEBUG $(ITT_NOTIFY) -g -O0 -DUSE_PTHREAD
-@@ -74,24 +74,12 @@ endif
-
- ifeq (intel64,$(arch))
- ITT_NOTIFY = -DDO_ITT_NOTIFY
-- CPLUS_FLAGS += -m64 $(RTM_KEY)
-- LIB_LINK_FLAGS += -m64
-+ CPLUS_FLAGS += $(RTM_KEY)
- endif
-
- ifeq (ia32,$(arch))
- ITT_NOTIFY = -DDO_ITT_NOTIFY
-- CPLUS_FLAGS += -m32 -march=pentium4 $(RTM_KEY)
-- LIB_LINK_FLAGS += -m32
--endif
--
--ifeq (ppc64,$(arch))
-- CPLUS_FLAGS += -m64
-- LIB_LINK_FLAGS += -m64
--endif
--
--ifeq (ppc32,$(arch))
-- CPLUS_FLAGS += -m32
-- LIB_LINK_FLAGS += -m32
-+ CPLUS_FLAGS += $(RTM_KEY)
- endif
-
- ifeq (bg,$(arch))
-@@ -99,12 +87,6 @@ ifeq (bg,$(arch))
- CONLY = $(firstword $(notdir $(shell which powerpc{64,32,}-bg{z..a}-linux-gcc 2>/dev/null)))
- endif
-
--# for some gcc versions on Solaris, -m64 may imply V9, but perhaps not everywhere (TODO: verify)
--ifeq (sparc,$(arch))
-- CPLUS_FLAGS += -mcpu=v9 -m64
-- LIB_LINK_FLAGS += -mcpu=v9 -m64
--endif
--
- # automatically generate "IT" instructions when compiling for Thumb ISA
- ifeq (armv7,$(arch))
- CPLUS_FLAGS += -Wa,-mimplicit-it=thumb
-@@ -113,13 +95,7 @@ endif
- #------------------------------------------------------------------------------
- # Setting assembler data.
- #------------------------------------------------------------------------------
--ASM = as
--ifeq (intel64,$(arch))
-- ASM_FLAGS += --64
--endif
--ifeq (ia32,$(arch))
-- ASM_FLAGS += --32
--endif
-+ASM := $(AS)
- ifeq ($(cfg),debug)
- ASM_FLAGS += -g
- endif
diff --git a/dev-cpp/tbb/files/tbb-4.4.20160803-build.patch b/dev-cpp/tbb/files/tbb-4.4.20160803-build.patch
deleted file mode 100644
index f4af5de9e50d..000000000000
--- a/dev-cpp/tbb/files/tbb-4.4.20160803-build.patch
+++ /dev/null
@@ -1,187 +0,0 @@
---- a/build/FreeBSD.gcc.inc
-+++ b/build/FreeBSD.gcc.inc
-@@ -28,8 +28,8 @@ WARNING_KEY = -Wall
- DYLIB_KEY = -shared
- WARNING_SUPPRESS = -Wno-parentheses
-
--CPLUS = g++
--CONLY = gcc
-+CPLUS = $(CXX)
-+CONLY = $(CC)
- LIB_LINK_FLAGS = -shared
- LIBS = -lpthread
- C_FLAGS = $(CPLUS_FLAGS)
-@@ -42,7 +42,7 @@ ifneq (,$(shell gcc -dumpversion | egrep "^([6-9])"))
- endif
-
- ifeq ($(cfg), release)
-- CPLUS_FLAGS = -g -O2 -DUSE_PTHREAD
-+ CPLUS_FLAGS = -g -DUSE_PTHREAD
- endif
- ifeq ($(cfg), debug)
- CPLUS_FLAGS = -DTBB_USE_DEBUG -g -O0 -DUSE_PTHREAD
-@@ -59,22 +59,12 @@ ifeq (ia64,$(arch))
- CPLUS_FLAGS += $(PIC_KEY)
- endif
-
--ifeq (intel64,$(arch))
-- CPLUS_FLAGS += -m64
-- LIB_LINK_FLAGS += -m64
--endif
--
--ifeq (ia32,$(arch))
-- CPLUS_FLAGS += -m32
-- LIB_LINK_FLAGS += -m32
--endif
--
- #------------------------------------------------------------------------------
- # Setting assembler data.
- #------------------------------------------------------------------------------
- ASSEMBLY_SOURCE=$(arch)-gas
- ifeq (ia64,$(arch))
-- ASM=as
-+ ASM=$(AS)
- TBB_ASM.OBJ = atomic_support.o lock_byte.o log2.o pause.o
- MALLOC_ASM.OBJ = atomic_support.o lock_byte.o pause.o
- endif
---- a/build/linux.clang.inc
-+++ b/build/linux.clang.inc
-@@ -31,15 +31,15 @@ DYLIB_KEY = -shared
- EXPORT_KEY = -Wl,--version-script,
- LIBDL = -ldl
-
--CPLUS = clang++
--CONLY = clang
-+CPLUS := $(CXX)
-+CONLY := $(CC)
- LIB_LINK_FLAGS = $(DYLIB_KEY) -Wl,-soname=$(BUILDING_LIBRARY)
- LIBS += -lpthread -lrt
- LINK_FLAGS = -Wl,-rpath-link=. -rdynamic
- C_FLAGS = $(CPLUS_FLAGS)
-
- ifeq ($(cfg), release)
-- CPLUS_FLAGS = $(ITT_NOTIFY) -g -O2 -DUSE_PTHREAD
-+ CPLUS_FLAGS = $(ITT_NOTIFY) -g -DUSE_PTHREAD
- endif
- ifeq ($(cfg), debug)
- CPLUS_FLAGS = -DTBB_USE_DEBUG $(ITT_NOTIFY) -g -O0 -DUSE_PTHREAD
-@@ -55,24 +55,10 @@ MALLOC_ASM.OBJ=
-
- ifeq (intel64,$(arch))
- ITT_NOTIFY = -DDO_ITT_NOTIFY
-- CPLUS_FLAGS += -m64
-- LIB_LINK_FLAGS += -m64
- endif
-
- ifeq (ia32,$(arch))
- ITT_NOTIFY = -DDO_ITT_NOTIFY
-- CPLUS_FLAGS += -m32 -march=pentium4
-- LIB_LINK_FLAGS += -m32
--endif
--
--ifeq (ppc64,$(arch))
-- CPLUS_FLAGS += -m64
-- LIB_LINK_FLAGS += -m64
--endif
--
--ifeq (ppc32,$(arch))
-- CPLUS_FLAGS += -m32
-- LIB_LINK_FLAGS += -m32
- endif
-
- ifeq (bg,$(arch))
-@@ -84,12 +70,6 @@ endif
- # Setting assembler data.
- #------------------------------------------------------------------------------
- ASM = as
--ifeq (intel64,$(arch))
-- ASM_FLAGS += --64
--endif
--ifeq (ia32,$(arch))
-- ASM_FLAGS += --32
--endif
- ifeq ($(cfg),debug)
- ASM_FLAGS += -g
- endif
---- a/build/linux.gcc.inc
-+++ b/build/linux.gcc.inc
-@@ -32,12 +32,12 @@ DYLIB_KEY = -shared
- EXPORT_KEY = -Wl,--version-script,
- LIBDL = -ldl
-
--CPLUS = g++
--CONLY = gcc
-+CPLUS := $(CXX)
-+CONLY := $(CC)
- LIB_LINK_FLAGS = $(DYLIB_KEY) -Wl,-soname=$(BUILDING_LIBRARY)
- LIBS += -lpthread -lrt
- LINK_FLAGS = -Wl,-rpath-link=. -rdynamic
--C_FLAGS = $(CPLUS_FLAGS)
-+C_FLAGS := $(CPLUS_FLAGS)
-
- # gcc 4.2 and higher support OpenMP
- ifneq (,$(shell gcc -dumpversion | egrep "^(4\.[2-9]|[5-9])"))
-@@ -57,7 +57,7 @@ ifneq (,$(shell gcc -dumpversion | egrep "^([6-9])"))
- endif
-
- ifeq ($(cfg), release)
-- CPLUS_FLAGS = $(ITT_NOTIFY) -g -O2 -DUSE_PTHREAD
-+ CPLUS_FLAGS = $(ITT_NOTIFY) -g -DUSE_PTHREAD
- endif
- ifeq ($(cfg), debug)
- CPLUS_FLAGS = -DTBB_USE_DEBUG $(ITT_NOTIFY) -g -O0 -DUSE_PTHREAD
-@@ -73,24 +73,12 @@ endif
-
- ifeq (intel64,$(arch))
- ITT_NOTIFY = -DDO_ITT_NOTIFY
-- CPLUS_FLAGS += -m64 $(RTM_KEY)
-- LIB_LINK_FLAGS += -m64
-+ CPLUS_FLAGS += $(RTM_KEY)
- endif
-
- ifeq (ia32,$(arch))
- ITT_NOTIFY = -DDO_ITT_NOTIFY
-- CPLUS_FLAGS += -m32 -march=pentium4 $(RTM_KEY)
-- LIB_LINK_FLAGS += -m32
--endif
--
--ifeq (ppc64,$(arch))
-- CPLUS_FLAGS += -m64
-- LIB_LINK_FLAGS += -m64
--endif
--
--ifeq (ppc32,$(arch))
-- CPLUS_FLAGS += -m32
-- LIB_LINK_FLAGS += -m32
-+ CPLUS_FLAGS += $(RTM_KEY)
- endif
-
- ifeq (bg,$(arch))
-@@ -98,12 +86,6 @@ ifeq (bg,$(arch))
- CONLY = $(firstword $(notdir $(shell which powerpc{64,32,}-bg{z..a}-linux-gcc 2>/dev/null)))
- endif
-
--# for some gcc versions on Solaris, -m64 may imply V9, but perhaps not everywhere (TODO: verify)
--ifeq (sparc,$(arch))
-- CPLUS_FLAGS += -mcpu=v9 -m64
-- LIB_LINK_FLAGS += -mcpu=v9 -m64
--endif
--
- # automatically generate "IT" instructions when compiling for Thumb ISA
- ifeq (armv7,$(arch))
- CPLUS_FLAGS += -Wa,-mimplicit-it=thumb
-@@ -112,13 +94,7 @@ endif
- #------------------------------------------------------------------------------
- # Setting assembler data.
- #------------------------------------------------------------------------------
--ASM = as
--ifeq (intel64,$(arch))
-- ASM_FLAGS += --64
--endif
--ifeq (ia32,$(arch))
-- ASM_FLAGS += --32
--endif
-+ASM := $(AS)
- ifeq ($(cfg),debug)
- ASM_FLAGS += -g
- endif
diff --git a/dev-cpp/tbb/files/tbb-4.4.20160803-underlinking.patch b/dev-cpp/tbb/files/tbb-4.4.20160803-underlinking.patch
deleted file mode 100644
index 5935017a325e..000000000000
--- a/dev-cpp/tbb/files/tbb-4.4.20160803-underlinking.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-https://bugs.gentoo.org/show_bug.cgi?id=418447
-
---- a/build/Makefile.test
-+++ b/build/Makefile.test
-@@ -44,8 +44,8 @@
- USE_PROXY_FLAG = $(DEFINE_KEY)HARNESS_USE_PROXY
- CPLUS_FLAGS += $(USE_PROXY_FLAG)
- LINK_TBB.LIB = $(PROXY.LIB)
-- LIBS += $(LIBDL)
--endif
-+endif
-+LIBS += $(LIBDL)
-
- TEST_SUFFIXES=secondary compiler_builtins pic
- include $(tbb_root)/build/common_rules.inc