summaryrefslogtreecommitdiff
path: root/dev-cpp/sol2/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-20 01:01:31 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-20 01:01:31 +0000
commit5d0c0ffd63620a4db788484bd36ab92b76e7891b (patch)
treeb4204d122504a5c2d3bfdb2cc9f3a5dcf5fe07b2 /dev-cpp/sol2/files
parent60945053af0588a6219a4a6867aace9e7b47faeb (diff)
gentoo auto-resync : 20:11:2022 - 01:01:31
Diffstat (limited to 'dev-cpp/sol2/files')
-rw-r--r--dev-cpp/sol2/files/sol2-3.2.2-catch-depend.patch27
-rw-r--r--dev-cpp/sol2/files/sol2-3.2.2-gcc11.patch10
2 files changed, 0 insertions, 37 deletions
diff --git a/dev-cpp/sol2/files/sol2-3.2.2-catch-depend.patch b/dev-cpp/sol2/files/sol2-3.2.2-catch-depend.patch
deleted file mode 100644
index 2da3c00c1612..000000000000
--- a/dev-cpp/sol2/files/sol2-3.2.2-catch-depend.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-Use catch library from system
-
---- a/tests/runtime_tests/CMakeLists.txt
-+++ b/tests/runtime_tests/CMakeLists.txt
-@@ -22,12 +22,6 @@
-
- # # # # sol3 tests - runtime tests
-
--if (CMAKE_GENERATOR MATCHES "Visual Studio 14 2015")
-- find_package(Catch 1.12.1 REQUIRED)
--else()
-- find_package(Catch REQUIRED)
--endif()
--
- file(GLOB SOL2_RUNTIME_TEST_SOURCES source/*.cpp)
- source_group(test_sources FILES ${SOL2_RUNTIME_TEST_SOURCES})
-
-@@ -38,7 +32,8 @@ function(CREATE_TEST test_target_name test_name target_sol)
- OUTPUT_NAME ${test_name}
- EXPORT_NAME sol2::${test_name})
- target_link_libraries(${test_target_name}
-- PUBLIC Threads::Threads ${LUA_LIBRARIES} ${CATCH_LIBRARIES} ${target_sol})
-+ PUBLIC Threads::Threads ${LUA_LIBRARIES} ${target_sol})
-+ target_include_directories(${test_target_name} PRIVATE ${CATCH_INC_DIR})
-
- if (MSVC)
- if (NOT CMAKE_COMPILER_ID MATCHES "Clang")
diff --git a/dev-cpp/sol2/files/sol2-3.2.2-gcc11.patch b/dev-cpp/sol2/files/sol2-3.2.2-gcc11.patch
deleted file mode 100644
index cc8c6bb1b4f7..000000000000
--- a/dev-cpp/sol2/files/sol2-3.2.2-gcc11.patch
+++ /dev/null
@@ -1,10 +0,0 @@
-Add missing include needed for tests (and possibly consumers) with gcc11.
-
-Fixed upstream in:
-https://github.com/ThePhD/sol2/commit/e5e6466e09b632677d24a8f204d6a0ea0a8862b1
---- a/include/sol/stack_core.hpp
-+++ b/include/sol/stack_core.hpp
-@@ -42,2 +42,3 @@
- #include <string>
-+#include <limits>
- #include <algorithm>