summaryrefslogtreecommitdiff
path: root/dev-cpp/sdbus-c++/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-17 04:54:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-17 04:54:15 +0000
commit04a96556dc0036655ac429edf598cc48febe294b (patch)
tree6577b5fabfcb1cee8eac4db1da2a0df03e5406a8 /dev-cpp/sdbus-c++/files
parentb7a94956953b9eb949dbf7a2b05fff47558c99a8 (diff)
gentoo auto-resync : 17:11:2023 - 04:54:15
Diffstat (limited to 'dev-cpp/sdbus-c++/files')
-rw-r--r--dev-cpp/sdbus-c++/files/sdbus-c++-1.4.0-gcc-14.patch25
-rw-r--r--dev-cpp/sdbus-c++/files/sdbus-c++-pc-reqs.patch29
-rw-r--r--dev-cpp/sdbus-c++/files/sdbus-c++-static-libsystemd.patch10
3 files changed, 25 insertions, 39 deletions
diff --git a/dev-cpp/sdbus-c++/files/sdbus-c++-1.4.0-gcc-14.patch b/dev-cpp/sdbus-c++/files/sdbus-c++-1.4.0-gcc-14.patch
new file mode 100644
index 000000000000..2b2671e3ea12
--- /dev/null
+++ b/dev-cpp/sdbus-c++/files/sdbus-c++-1.4.0-gcc-14.patch
@@ -0,0 +1,25 @@
+From 066785da67f0d7e2fa5f45c0fb25c333679be061 Mon Sep 17 00:00:00 2001
+From: Alfred Wingate <parona@protonmail.com>
+Date: Thu, 16 Nov 2023 18:52:48 +0200
+Subject: [PATCH] fix: Add header for gcc-14 that isn't included by default
+ anymore
+
+* https://gcc.gnu.org/gcc-14/porting_to.html
+
+Signed-off-by: Alfred Wingate <parona@protonmail.com>
+---
+ include/sdbus-c++/Message.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/include/sdbus-c++/Message.h b/include/sdbus-c++/Message.h
+index 915a071b..9c85c019 100644
+--- a/include/sdbus-c++/Message.h
++++ b/include/sdbus-c++/Message.h
+@@ -42,6 +42,7 @@
+ #include <cassert>
+ #include <functional>
+ #include <sys/types.h>
++#include <algorithm>
+
+ // Forward declarations
+ namespace sdbus {
diff --git a/dev-cpp/sdbus-c++/files/sdbus-c++-pc-reqs.patch b/dev-cpp/sdbus-c++/files/sdbus-c++-pc-reqs.patch
deleted file mode 100644
index 9730bda5bc65..000000000000
--- a/dev-cpp/sdbus-c++/files/sdbus-c++-pc-reqs.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 0733b41..fd613be 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -210,6 +210,11 @@ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/cmake/sdbus-c++-config.cmake
- DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/sdbus-c++
- COMPONENT dev)
-
-+if(BUILD_LIBSYSTEMD OR pkgcfg_lib_Systemd_systemd MATCHES "\.a$")
-+ set(PKGCONFIG_REQS "")
-+else()
-+ set(PKGCONFIG_REQS "libsystemd")
-+endif()
- configure_file(pkgconfig/sdbus-c++.pc.in pkgconfig/sdbus-c++.pc @ONLY)
- install(FILES ${CMAKE_CURRENT_BINARY_DIR}/pkgconfig/sdbus-c++.pc
- DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig COMPONENT dev)
-diff --git a/pkgconfig/sdbus-c++.pc.in b/pkgconfig/sdbus-c++.pc.in
-index 21e0f0b..a6d6ec9 100644
---- a/pkgconfig/sdbus-c++.pc.in
-+++ b/pkgconfig/sdbus-c++.pc.in
-@@ -5,7 +5,7 @@ includedir=@CMAKE_INSTALL_FULL_INCLUDEDIR@
-
- Name: @PROJECT_NAME@
- Description: C++ library on top of sd-bus, a systemd D-Bus library
--Requires: libsystemd
-+Requires: @PKGCONFIG_REQS@
- Version: @SDBUSCPP_VERSION@
- Libs: -L${libdir} -l@PROJECT_NAME@
- Cflags: -I${includedir}
diff --git a/dev-cpp/sdbus-c++/files/sdbus-c++-static-libsystemd.patch b/dev-cpp/sdbus-c++/files/sdbus-c++-static-libsystemd.patch
deleted file mode 100644
index d6f018fda175..000000000000
--- a/dev-cpp/sdbus-c++/files/sdbus-c++-static-libsystemd.patch
+++ /dev/null
@@ -1,10 +0,0 @@
-systemd does not include pkg-config dependencies for static linking.
-
-diff -Naur a/src/libsystemd/libsystemd.pc.in b/src/libsystemd/libsystemd.pc.in
---- a/src/libsystemd/libsystemd.pc.in 2022-01-18 11:35:43.000000000 +0000
-+++ b/src/libsystemd/libsystemd.pc.in 2022-03-05 21:24:47.139338880 +0000
-@@ -18,3 +18,4 @@
- Version: {{PROJECT_VERSION}}
- Libs: -L${libdir} -lsystemd
- Cflags: -I${includedir}
-+Requires: libcap