summaryrefslogtreecommitdiff
path: root/dev-cpp/scitokens-cpp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-08 15:45:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-08 15:45:39 +0100
commitd5599da3055bf9b900513a61c3c6e4bdbb524503 (patch)
treeb64a792286dd490c9d4fc2c46bbbaa64804efc61 /dev-cpp/scitokens-cpp
parentcfeee79886441e92c8ee094e45b9bcdc9c79137a (diff)
gentoo auto-resync : 08:06:2023 - 15:45:39
Diffstat (limited to 'dev-cpp/scitokens-cpp')
-rw-r--r--dev-cpp/scitokens-cpp/Manifest3
-rw-r--r--dev-cpp/scitokens-cpp/metadata.xml18
-rw-r--r--dev-cpp/scitokens-cpp/scitokens-cpp-1.0.1.ebuild34
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-cpp/scitokens-cpp/Manifest b/dev-cpp/scitokens-cpp/Manifest
new file mode 100644
index 000000000000..ef4f62c65e71
--- /dev/null
+++ b/dev-cpp/scitokens-cpp/Manifest
@@ -0,0 +1,3 @@
+DIST scitokens-cpp-1.0.1.tar.gz 309430 BLAKE2B cfb0a25bde68076334d37d0b47adcb2f1b794bf60330f612c3bfbe2588e420a2b427e9e9916ee14c2c348ed4448d781fad2068d35560b45740b81144aa12e6a6 SHA512 592d8c473ecdeed49c5552239d98e4da57313c8914b3c97c74a6bc4b1f4929b4490a33695e741972a8c83f6097d644fc4df94b3ca54d811c64dcf542b6467ea9
+EBUILD scitokens-cpp-1.0.1.ebuild 777 BLAKE2B ece63bbedbd9d5db682a490edaf2b25f1355f232a0af262b464ae5b72f72d9eb9ac6808d970bcc936e6bfad0ab3151a73231b9333fa2d74f76489dfc4e944a36 SHA512 a2f3caac29fa5e9f5531d71634a7509f8577f6f76eeff66a893797b3778bf3eca87b0343755ff50dc0e45c408b95bb43ca8f4bac90f0c030268572d2d19b675a
+MISC metadata.xml 787 BLAKE2B 69c8acc6bf065505f53697758868150f6b9ee723118fa83402522087772e3c76bdbb6a8206f4979c616e6ecade0a550d65b5c57e9ca4490a041351bae8e935d2 SHA512 312f619805e8fe7067f8ddad537e13d52c4ed0e2e9a9daba70187693febf800c61c3b5ec0b23d607b847daea1ff6d423aca4316f9a7116f06e909a8afe80e702
diff --git a/dev-cpp/scitokens-cpp/metadata.xml b/dev-cpp/scitokens-cpp/metadata.xml
new file mode 100644
index 000000000000..f04332ace873
--- /dev/null
+++ b/dev-cpp/scitokens-cpp/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>amadio@gentoo.org</email>
+ <name>Guilherme Amadio</name>
+ </maintainer>
+ <longdescription lang="en">
+ SciTokens provide a token format for distributed authorization. The tokens are
+ self-describing, can be verified in a distributed fashion (no need to contact
+ the issuer to determine if the token is valid). This is convenient for a
+ federated environment where several otherwise-independent storage endpoints
+ want to delegate trust for an issuer for managing a storage allocation.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">scitokens/scitokens-cpp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-cpp/scitokens-cpp/scitokens-cpp-1.0.1.ebuild b/dev-cpp/scitokens-cpp/scitokens-cpp-1.0.1.ebuild
new file mode 100644
index 000000000000..e6a43dfceee1
--- /dev/null
+++ b/dev-cpp/scitokens-cpp/scitokens-cpp-1.0.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="A C++ implementation of the SciTokens library with a C library interface"
+HOMEPAGE="https://github.com/scitokens/scitokens-cpp"
+SRC_URI="https://github.com/scitokens/scitokens-cpp/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RESTRICT="test" # testing requires network
+
+DEPEND="
+ dev-db/sqlite
+ dev-libs/openssl:0=
+ net-misc/curl:0=
+ kernel_linux? ( sys-apps/util-linux )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="test? ( dev-cpp/gtest )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DSCITOKENS_BUILD_UNITTESTS=$(usex test)
+ -DSCITOKENS_EXTERNAL_GTEST=1
+ )
+ cmake_src_configure
+}