summaryrefslogtreecommitdiff
path: root/dev-cpp/rttr/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /dev-cpp/rttr/files
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'dev-cpp/rttr/files')
-rw-r--r--dev-cpp/rttr/files/rttr-0.9.6-cmake.patch25
-rw-r--r--dev-cpp/rttr/files/rttr-0.9.6-permission.patch13
-rw-r--r--dev-cpp/rttr/files/rttr-0.9.6-tests.patch30
-rw-r--r--dev-cpp/rttr/files/rttr-0.9.6-werror.patch18
4 files changed, 86 insertions, 0 deletions
diff --git a/dev-cpp/rttr/files/rttr-0.9.6-cmake.patch b/dev-cpp/rttr/files/rttr-0.9.6-cmake.patch
new file mode 100644
index 000000000000..e313014d70a5
--- /dev/null
+++ b/dev-cpp/rttr/files/rttr-0.9.6-cmake.patch
@@ -0,0 +1,25 @@
+Install cmake files to the correct directory.
+
+Avoid installing docs to the wrong directory (will be installed by the ebuild instead).
+
+--- a/CMake/config.cmake
++++ b/CMake/config.cmake
+@@ -69,7 +69,7 @@
+
+ set(RTTR_INSTALL_FULL_LIBDIR "${CMAKE_INSTALL_FULL_LIBDIR}")
+
+- set(RTTR_CMAKE_CONFIG_INSTALL_DIR "${CMAKE_INSTALL_DATADIR}/rttr/cmake")
++ set(RTTR_CMAKE_CONFIG_INSTALL_DIR "${CMAKE_INSTALL_LIBDIR}/cmake/rttr")
+ set(RTTR_ADDITIONAL_FILES_INSTALL_DIR "${CMAKE_INSTALL_DATADIR}/rttr")
+
+ elseif(WIN32)
+@@ -169,8 +169,4 @@
+ install(FILES "${CMAKE_CURRENT_BINARY_DIR}/CMake/rttr-config-version.cmake"
+ DESTINATION ${RTTR_CMAKE_CONFIG_INSTALL_DIR}
+ COMPONENT Devel)
+-
+- install(FILES "${LICENSE_FILE}" "${README_FILE}"
+- DESTINATION ${RTTR_ADDITIONAL_FILES_INSTALL_DIR}
+- PERMISSIONS OWNER_READ)
+ endif()
+
diff --git a/dev-cpp/rttr/files/rttr-0.9.6-permission.patch b/dev-cpp/rttr/files/rttr-0.9.6-permission.patch
new file mode 100644
index 000000000000..bec7ac36bfc9
--- /dev/null
+++ b/dev-cpp/rttr/files/rttr-0.9.6-permission.patch
@@ -0,0 +1,13 @@
+Avoid installing headers with mode 700.
+
+--- a/CMake/utility.cmake
++++ b/CMake/utility.cmake
+@@ -165,7 +165,7 @@
+ getNameOfDir(CMAKE_CURRENT_SOURCE_DIR DIRNAME)
+ if (${shouldInstall})
+ if (NOT ${FULL_HEADER_PATH} MATCHES ".*_p.h$") # we don't want to install header files which are marked as private
+- install(FILES ${FULL_HEADER_PATH} DESTINATION "include/${DIRNAME}/${REL_PATH}" PERMISSIONS OWNER_READ)
++ install(FILES ${FULL_HEADER_PATH} DESTINATION "include/${DIRNAME}/${REL_PATH}")
+ endif()
+ endif()
+ endforeach()
diff --git a/dev-cpp/rttr/files/rttr-0.9.6-tests.patch b/dev-cpp/rttr/files/rttr-0.9.6-tests.patch
new file mode 100644
index 000000000000..bd966c3d327d
--- /dev/null
+++ b/dev-cpp/rttr/files/rttr-0.9.6-tests.patch
@@ -0,0 +1,30 @@
+Avoid running a custom testsuite unconditionally.
+
+--- a/src/unit_tests/CMakeLists.txt
++++ b/src/unit_tests/CMakeLists.txt
+@@ -54,17 +54,17 @@
+ endif()
+
+ # run tests
+-add_custom_target(run_tests ALL
+- COMMAND "$<TARGET_FILE:unit_tests>"
+- DEPENDS unit_tests
+- COMMENT "Running unit_tests")
++#add_custom_target(run_tests ALL
++# COMMAND "$<TARGET_FILE:unit_tests>"
++# DEPENDS unit_tests
++# COMMENT "Running unit_tests")
+
+-set_target_properties(run_tests PROPERTIES
+- FOLDER "Testing")
++#set_target_properties(run_tests PROPERTIES
++# FOLDER "Testing")
+
+ add_subdirectory(plugin)
+
+ add_dependencies(unit_tests unit_test_plugin)
+
+ message(STATUS "Scanning " ${PROJECT_NAME} " module finished!")
+-message(STATUS "")
+\ No newline at end of file
++message(STATUS "")
diff --git a/dev-cpp/rttr/files/rttr-0.9.6-werror.patch b/dev-cpp/rttr/files/rttr-0.9.6-werror.patch
new file mode 100644
index 000000000000..04c65203ac91
--- /dev/null
+++ b/dev-cpp/rttr/files/rttr-0.9.6-werror.patch
@@ -0,0 +1,18 @@
+This causes build failures with modern GCC, and is against Gentoo policy in any case.
+
+--- a/CMake/utility.cmake
++++ b/CMake/utility.cmake
+@@ -392,11 +392,9 @@
+ ####################################################################################
+ function( set_compiler_warnings target)
+ if(CMAKE_CXX_COMPILER_ID STREQUAL "GNU")
+- set(WARNINGS "-Werror"
+- "-Wall")
++ set(WARNINGS "-Wall")
+ elseif(CMAKE_CXX_COMPILER_ID MATCHES "Clang")
+- set(WARNINGS "-Werror"
+- "-Wall")
++ set(WARNINGS "-Wall")
+ elseif(MSVC)
+ set(WARNINGS "/WX"
+ "/W4")