summaryrefslogtreecommitdiff
path: root/dev-cpp/popl/popl-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
commit64e107b9b6058580ff0432107eb37cefb0b2a7d8 (patch)
tree9a44e603e2ae365e2b1fe35ac37f73e830cdee1d /dev-cpp/popl/popl-9999.ebuild
parent957235cf19a691360c720f7913672adda4258ed0 (diff)
gentoo resync : 22.10.2018
Diffstat (limited to 'dev-cpp/popl/popl-9999.ebuild')
-rw-r--r--dev-cpp/popl/popl-9999.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-cpp/popl/popl-9999.ebuild b/dev-cpp/popl/popl-9999.ebuild
new file mode 100644
index 000000000000..39652fbae851
--- /dev/null
+++ b/dev-cpp/popl/popl-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Header-only C++ program options parser library"
+HOMEPAGE="https://github.com/badaix/popl"
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit cmake-utils git-r3
+
+ EGIT_REPO_URI="https://github.com/badaix/popl.git"
+ EGIT_BRANCH="develop"
+else
+ inherit cmake-utils
+
+ SRC_URI="https://github.com/badaix/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+src_configure() {
+ local mycmakeargs=( -DBUILD_EXAMPLE=OFF )
+
+ cmake-utils_src_configure
+}