summaryrefslogtreecommitdiff
path: root/dev-cpp/pngpp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-cpp/pngpp
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-cpp/pngpp')
-rw-r--r--dev-cpp/pngpp/Manifest4
-rw-r--r--dev-cpp/pngpp/files/pngpp-0.2.9-DESTDIR.patch15
-rw-r--r--dev-cpp/pngpp/metadata.xml12
-rw-r--r--dev-cpp/pngpp/pngpp-0.2.9.ebuild34
4 files changed, 65 insertions, 0 deletions
diff --git a/dev-cpp/pngpp/Manifest b/dev-cpp/pngpp/Manifest
new file mode 100644
index 000000000000..73703490c4ca
--- /dev/null
+++ b/dev-cpp/pngpp/Manifest
@@ -0,0 +1,4 @@
+AUX pngpp-0.2.9-DESTDIR.patch 379 BLAKE2B 108fbb9547615a88e4a6576728ef21c1aa7a51ab807015064f28064b4c1583a4d4fbf5334d82da5fcc6af25aac0ea5898c58e2d08787fe03758b78dc1a5fe302 SHA512 21ec246b271d3715960cad9f57613aae35647d0d427d73dfb8cf847252d5dff5b53b02fd57fe76709be5f3dbd2ef9711a8d70cf3bb2ffde70e0c0f05ecbd37eb
+DIST png++-0.2.9.tar.gz 592770 BLAKE2B 12419e3c964f92022f992e25d2efcfb01c7f6275aba1db159372f84cbf0e0bf0e92e95dac419ff0f6248dd1ecf63918b11096e7e6baa8da5704909e69cb7aeca SHA512 905e037faf26eef9ca1d9508471dde9f480f41a87d72133057865078b2fd040b1cf84727ece48d79117d615fdfbc0a749fec7dbe362366763e2017865a7fe132
+EBUILD pngpp-0.2.9.ebuild 669 BLAKE2B fc8d466f62a834c96eb34095e008110746ded67cff3fe993ad3017f2de2c7e473819aaec45645e913cb3f30628c2b5e4dbc1dd3112074a31a902b0dbbc34a89d SHA512 e0c897e3cf3caca80e1bfd98c3bb6ed0762b86842cc3f23ae7531c7e292fc8f835214d6d58535dbd8afc620b5344f4348a13ae388a31f0e26eec9310b37e2dc4
+MISC metadata.xml 361 BLAKE2B 9c5ed9620701eb1faabaab1200f3c00f36df9a11b246b3e16e6d87e98f11f113c2de41441bbde977c3313d9cdf1afed3ce851cd05cfb066a7fdb9c8732b92a77 SHA512 12569f0d3772bc306792160436a2c025f275e410744efba50728e6b925295f80529929e97f9a6b65a97915dd8bdb2561874537b0bf24cdb583159f5053128275
diff --git a/dev-cpp/pngpp/files/pngpp-0.2.9-DESTDIR.patch b/dev-cpp/pngpp/files/pngpp-0.2.9-DESTDIR.patch
new file mode 100644
index 000000000000..ee9b29ef7558
--- /dev/null
+++ b/dev-cpp/pngpp/files/pngpp-0.2.9-DESTDIR.patch
@@ -0,0 +1,15 @@
+Build system does not honour $(DESTDIR)
+
+--- a/Makefile
++++ b/Makefile
+@@ -54,8 +54,8 @@
+ uninstall: uninstall-headers uninstall-docs
+
+ install-headers:
+- mkdir -p $(PREFIX)/include/png++
+- cp $(headers) $(PREFIX)/include/png++
++ mkdir -p $(DESTDIR)$(PREFIX)/include/png++
++ cp $(headers) $(DESTDIR)$(PREFIX)/include/png++
+
+ uninstall-headers:
+ rm -rf $(PREFIX)/include/png++
diff --git a/dev-cpp/pngpp/metadata.xml b/dev-cpp/pngpp/metadata.xml
new file mode 100644
index 000000000000..5ea2520054ed
--- /dev/null
+++ b/dev-cpp/pngpp/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>graphics@gentoo.org</email>
+ <name>Gentoo Graphics Project</name>
+</maintainer>
+<maintainer type="project">
+ <email>cpp@gentoo.org</email>
+ <name>Gentoo C++ Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-cpp/pngpp/pngpp-0.2.9.ebuild b/dev-cpp/pngpp/pngpp-0.2.9.ebuild
new file mode 100644
index 000000000000..4e013690de88
--- /dev/null
+++ b/dev-cpp/pngpp/pngpp-0.2.9.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_P=${P/pp/++}
+
+DESCRIPTION="A simple but powerful C++ interface to libpng"
+HOMEPAGE="http://www.nongnu.org/pngpp/"
+SRC_URI="mirror://nongnu/${PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="media-libs/libpng:0"
+DEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=( "${FILESDIR}"/${PN}-0.2.9-DESTDIR.patch )
+
+src_compile() { :; }
+src_test() { :; }
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install-headers
+ einstalldocs
+
+ docinto examples
+ dodoc example/*.cpp
+ docompress -x /usr/share/doc/${PF}/examples
+}