summaryrefslogtreecommitdiff
path: root/dev-cpp/nlohmann_json/nlohmann_json-3.9.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
commit24fd814c326e282c4321965c31f341dad77e270d (patch)
tree033d63b33c21a3209964ab56005bb9bdd523630d /dev-cpp/nlohmann_json/nlohmann_json-3.9.1.ebuild
parent129160ec854dca4c3fedb5bcfbcb56930371da0f (diff)
gentoo resync : 08.01.2021
Diffstat (limited to 'dev-cpp/nlohmann_json/nlohmann_json-3.9.1.ebuild')
-rw-r--r--dev-cpp/nlohmann_json/nlohmann_json-3.9.1.ebuild33
1 files changed, 15 insertions, 18 deletions
diff --git a/dev-cpp/nlohmann_json/nlohmann_json-3.9.1.ebuild b/dev-cpp/nlohmann_json/nlohmann_json-3.9.1.ebuild
index cbad769efb0c..9e63f828a377 100644
--- a/dev-cpp/nlohmann_json/nlohmann_json-3.9.1.ebuild
+++ b/dev-cpp/nlohmann_json/nlohmann_json-3.9.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -7,8 +7,9 @@ inherit cmake
DESCRIPTION="JSON for Modern C++"
HOMEPAGE="https://github.com/nlohmann/json https://nlohmann.github.io/json/"
-SRC_URI="https://github.com/nlohmann/json/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-SRC_URI+=" test? ( https://github.com/nlohmann/json_test_data/archive/v3.0.0.tar.gz -> ${P}-testdata.tar.gz )"
+SRC_URI="
+ https://github.com/nlohmann/json/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ test? ( https://github.com/nlohmann/json_test_data/archive/v3.0.0.tar.gz -> ${P}-testdata.tar.gz )"
S="${WORKDIR}/json-${PV}"
LICENSE="MIT"
@@ -20,29 +21,30 @@ IUSE="doc test"
# Tests only just added, large test suite, majority pass
RESTRICT="test"
-DEPEND="doc? ( app-doc/doxygen )"
+BDEPEND="doc? ( app-doc/doxygen )"
DOCS=( ChangeLog.md README.md )
src_configure() {
+ # Tests are built by default so we can't group the test logic below
local mycmakeargs=(
-DJSON_MultipleHeaders=ON
+ -DJSON_BuildTests=$(usex test)
)
- if use test ; then
- # Define test data directory here to avoid unused var QA warning
- # #747826
- mycmakeargs+=(
- -DJSON_BuildTests=ON
- -DJSON_TestDataDirectory="${S}/json_test_data"
- )
- fi
+ # Define test data directory here to avoid unused var QA warning, bug #747826
+ use test && mycmakeargs+=( -DJSON_TestDataDirectory="${S}"/json_test_data )
+
cmake_src_configure
}
src_compile() {
cmake_src_compile
- use doc && emake -C doc
+
+ if use doc; then
+ emake -C doc
+ HTML_DOCS=( doc/html/. )
+ fi
}
src_test() {
@@ -56,8 +58,3 @@ src_test() {
cmake_src_test
}
-
-src_install() {
- cmake_src_install
- use doc && dodoc -r doc/html
-}