summaryrefslogtreecommitdiff
path: root/dev-cpp/ms-gsl/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-cpp/ms-gsl/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-cpp/ms-gsl/files')
-rw-r--r--dev-cpp/ms-gsl/files/ms-gsl-1.0.0-disable_Werror-644042.patch35
-rw-r--r--dev-cpp/ms-gsl/files/ms-gsl-1.0.0-use_system_catch-636828.patch21
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-cpp/ms-gsl/files/ms-gsl-1.0.0-disable_Werror-644042.patch b/dev-cpp/ms-gsl/files/ms-gsl-1.0.0-disable_Werror-644042.patch
new file mode 100644
index 000000000000..35c8177cad8a
--- /dev/null
+++ b/dev-cpp/ms-gsl/files/ms-gsl-1.0.0-disable_Werror-644042.patch
@@ -0,0 +1,35 @@
+From 683aacce5b642a3c735f8040601e0de345d028da Mon Sep 17 00:00:00 2001
+From: Jan Henke <Jan.Henke@taujhe.de>
+Date: Sat, 17 Mar 2018 19:47:52 +0100
+Subject: [PATCH] Disable -WError when compiling tests
+
+GCC 7 generates new warnings on some of the test files, which lead to
+build failures. -WError generally is helpful while developing to enforce
+a zero error policy, but not so much when packaging. Gentoo bug 644042
+---
+ tests/CMakeLists.txt | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
+index 0e08d77..86e9af7 100644
+--- a/tests/CMakeLists.txt
++++ b/tests/CMakeLists.txt
+@@ -41,7 +41,6 @@ target_compile_options(gsl_tests_config INTERFACE
+ -Wcast-align
+ -Wconversion
+ -Wctor-dtor-privacy
+- -Werror
+ -Wextra
+ -Wno-missing-braces
+ -Wnon-virtual-dtor
+@@ -129,7 +128,6 @@ target_compile_options(gsl_tests_config_noexcept INTERFACE
+ -Wcast-align
+ -Wconversion
+ -Wctor-dtor-privacy
+- -Werror
+ -Wextra
+ -Wno-missing-braces
+ -Wnon-virtual-dtor
+--
+2.16.1
+
diff --git a/dev-cpp/ms-gsl/files/ms-gsl-1.0.0-use_system_catch-636828.patch b/dev-cpp/ms-gsl/files/ms-gsl-1.0.0-use_system_catch-636828.patch
new file mode 100644
index 000000000000..12d92605dda8
--- /dev/null
+++ b/dev-cpp/ms-gsl/files/ms-gsl-1.0.0-use_system_catch-636828.patch
@@ -0,0 +1,21 @@
+Add CMake option to disable upstream's catch download, we always want to use the
+system wide installed version. Gentoo bug 636828.
+
+diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
+index 86ce5a4..b36df56 100644
+--- a/tests/CMakeLists.txt
++++ b/tests/CMakeLists.txt
+@@ -10,7 +10,9 @@ list(APPEND CATCH_CMAKE_ARGS
+ "-DNO_SELFTEST=true"
+ )
+
+-if(GIT_FOUND)
++option(FORCE_SYSTEM_CATCH "Force usage of system-wide catch install" OFF)
++
++if(NOT ${FORCE_SYSTEM_CATCH} AND GIT_FOUND)
+ # add catch
+ ExternalProject_Add(
+ catch
+--
+2.13.6
+