summaryrefslogtreecommitdiff
path: root/dev-cpp/ms-gsl/files/ms-gsl-1.0.0-use_system_catch-636828.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-02 14:13:35 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-02 14:13:35 +0100
commit7c7c2c9727d6b2ff30945b5aea0d575e1c406d8b (patch)
treebac2a67fb24ac0836147fe370d30e1610ae1845d /dev-cpp/ms-gsl/files/ms-gsl-1.0.0-use_system_catch-636828.patch
parent2f8db31405fac68eea6f7257d58529243815033b (diff)
gentoo resync : 02.05.2018
Diffstat (limited to 'dev-cpp/ms-gsl/files/ms-gsl-1.0.0-use_system_catch-636828.patch')
-rw-r--r--dev-cpp/ms-gsl/files/ms-gsl-1.0.0-use_system_catch-636828.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-cpp/ms-gsl/files/ms-gsl-1.0.0-use_system_catch-636828.patch b/dev-cpp/ms-gsl/files/ms-gsl-1.0.0-use_system_catch-636828.patch
new file mode 100644
index 000000000000..12d92605dda8
--- /dev/null
+++ b/dev-cpp/ms-gsl/files/ms-gsl-1.0.0-use_system_catch-636828.patch
@@ -0,0 +1,21 @@
+Add CMake option to disable upstream's catch download, we always want to use the
+system wide installed version. Gentoo bug 636828.
+
+diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
+index 86ce5a4..b36df56 100644
+--- a/tests/CMakeLists.txt
++++ b/tests/CMakeLists.txt
+@@ -10,7 +10,9 @@ list(APPEND CATCH_CMAKE_ARGS
+ "-DNO_SELFTEST=true"
+ )
+
+-if(GIT_FOUND)
++option(FORCE_SYSTEM_CATCH "Force usage of system-wide catch install" OFF)
++
++if(NOT ${FORCE_SYSTEM_CATCH} AND GIT_FOUND)
+ # add catch
+ ExternalProject_Add(
+ catch
+--
+2.13.6
+