summaryrefslogtreecommitdiff
path: root/dev-cpp/mm-common/mm-common-1.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-cpp/mm-common/mm-common-1.0.1.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-cpp/mm-common/mm-common-1.0.1.ebuild')
-rw-r--r--dev-cpp/mm-common/mm-common-1.0.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-cpp/mm-common/mm-common-1.0.1.ebuild b/dev-cpp/mm-common/mm-common-1.0.1.ebuild
new file mode 100644
index 000000000000..ba4c89f0371d
--- /dev/null
+++ b/dev-cpp/mm-common/mm-common-1.0.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org meson
+
+DESCRIPTION="Build infrastructure and utilities for GNOME C++ bindings"
+HOMEPAGE="https://www.gtkmm.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+src_prepare() {
+ default
+
+ # Include project version in docdir name
+ sed -i -e "s:^install_docdir.*:& + '-' + meson.project_version():" meson.build || die
+}