summaryrefslogtreecommitdiff
path: root/dev-cpp/libmcpp/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-09 16:40:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-09 16:40:34 +0100
commit9257212a8841f37588d5b5a94a7930db4585a106 (patch)
tree8ee63d1ea86eee544e495fadca1e7f0a5280b816 /dev-cpp/libmcpp/files
parentb426a5cef3f0ebe3389686a1c145a834d3a1e120 (diff)
gentoo auto-resync : 09:09:2022 - 16:40:34
Diffstat (limited to 'dev-cpp/libmcpp/files')
-rw-r--r--dev-cpp/libmcpp/files/libmcpp-2.7.2-fix-configure-checks.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-cpp/libmcpp/files/libmcpp-2.7.2-fix-configure-checks.patch b/dev-cpp/libmcpp/files/libmcpp-2.7.2-fix-configure-checks.patch
new file mode 100644
index 000000000000..e7bb77d6cf41
--- /dev/null
+++ b/dev-cpp/libmcpp/files/libmcpp-2.7.2-fix-configure-checks.patch
@@ -0,0 +1,34 @@
+https://cgit.openembedded.org/meta-openembedded/plain/meta-oe/recipes-devtools/mcpp/files/0001-configure-Fix-checks-for-system-headers.patch?id=6721430ca97aa98208cc1c450e4e8c4c274ca840
+
+From c1e9f2f3d086e0df3c10a2468fd7b37fd0c5038c Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Wed, 7 Sep 2022 00:02:08 -0700
+Subject: [PATCH] configure: Fix checks for system headers
+
+Define _DEFAULT_SOURCE in system.c so unistd.h can expose readlink API
+
+Upstream-Status: Pending
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+--- a/configure.ac
++++ b/configure.ac
+@@ -152,7 +152,7 @@ fi
+
+ dnl Checks for header files.
+
+-AC_CHECK_HEADERS( [unistd.h, stdint.h, inttypes.h])
++AC_CHECK_HEADERS( [unistd.h stdint.h inttypes.h])
+
+ dnl Checks for typedefs, and compiler characteristics.
+
+--- a/src/system.c
++++ b/src/system.c
+@@ -36,6 +36,8 @@
+ * 1. specify the constants in "configed.H" or "noconfig.H",
+ * 2. append the system-dependent routines in this file.
+ */
++
++#define _DEFAULT_SOURCE
+ #if PREPROCESSED
+ #include "mcpp.H"
+ #else