summaryrefslogtreecommitdiff
path: root/dev-cpp/libmcpp/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-cpp/libmcpp/files
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-cpp/libmcpp/files')
-rw-r--r--dev-cpp/libmcpp/files/libmcpp-2.7.2-fix-build-system.patch30
-rw-r--r--dev-cpp/libmcpp/files/libmcpp-2.7.2-gniibe.patch33
-rw-r--r--dev-cpp/libmcpp/files/libmcpp-2.7.2-zeroc.patch75
3 files changed, 0 insertions, 138 deletions
diff --git a/dev-cpp/libmcpp/files/libmcpp-2.7.2-fix-build-system.patch b/dev-cpp/libmcpp/files/libmcpp-2.7.2-fix-build-system.patch
deleted file mode 100644
index 95cefadd3fe8..000000000000
--- a/dev-cpp/libmcpp/files/libmcpp-2.7.2-fix-build-system.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-Specify and install files using idiomatic Automake
-conventions instead of manually installing with cp.
-
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -23,16 +23,12 @@
- $(top_srcdir)/test-c $(top_srcdir)/test-l $(top_srcdir)/tool \
- $(top_srcdir)/doc $(top_srcdir)/doc-jp
-
--if ! REPLACE_CPP
--install-exec-hook:
-- $(top_srcdir)/config/install-sh -d "$(DESTDIR)$(prefix)/share/doc/mcpp"
-- cp -pf $(top_srcdir)/LICENSE $(top_srcdir)/README $(top_srcdir)/NEWS \
-- $(DESTDIR)$(prefix)/share/doc/mcpp
-- cp -pf $(top_srcdir)/doc/mcpp-manual.html \
-- $(DESTDIR)$(prefix)/share/doc/mcpp
-- cp -pf $(top_srcdir)/doc-jp/mcpp-manual.html \
-- $(DESTDIR)$(prefix)/share/doc/mcpp/mcpp-manual-jp.html
--uninstall-hook:
-- rm -rf $(DESTDIR)$(prefix)/share/doc/mcpp
--endif
-+dist_doc_DATA = README NEWS doc/mcpp-summary.pdf
-
-+dist_html_DATA = \
-+ doc/cpp-test.html \
-+ doc/mcpp-manual.html \
-+ doc/mcpp-porting.html
-+
-+htmljadir = $(htmldir)/doc-jp
-+dist_htmlja_DATA = doc-jp/mcpp-manual.html
diff --git a/dev-cpp/libmcpp/files/libmcpp-2.7.2-gniibe.patch b/dev-cpp/libmcpp/files/libmcpp-2.7.2-gniibe.patch
deleted file mode 100644
index cb5aa6c345ce..000000000000
--- a/dev-cpp/libmcpp/files/libmcpp-2.7.2-gniibe.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-Description: Simple fixes
- * Fix freeing unmalloced memory
- The memory of 'in_file' is not malloced, but points to argv[].
- It is wrong to free it.
- * When there is no input file specified by argv, it causes error
- and fp_in == NULL. Check is needed to call fclose for fp_in.
-Author: NIIBE Yutaka
-
-## Fixes the issue reported at:
-## http://www.forallsecure.com/bug-reports/6b11b6fccda17cc467e055ccf7fec3fa2d89ec00/
-
-Index: mcpp-2.7.2/src/main.c
-===================================================================
---- mcpp-2.7.2.orig/src/main.c 2013-07-09 03:03:05.610947658 +0000
-+++ mcpp-2.7.2/src/main.c 2013-07-09 03:03:05.534947624 +0000
-@@ -428,16 +428,11 @@
-
- fatal_error_exit:
- #if MCPP_LIB
-- /* Free malloced memory */
-- if (mcpp_debug & MACRO_CALL) {
-- if (in_file != stdin_name)
-- free( in_file);
-- }
- clear_filelist();
- clear_symtable();
- #endif
-
-- if (fp_in != stdin)
-+ if (fp_in && fp_in != stdin)
- fclose( fp_in);
- if (fp_out != stdout)
- fclose( fp_out);
diff --git a/dev-cpp/libmcpp/files/libmcpp-2.7.2-zeroc.patch b/dev-cpp/libmcpp/files/libmcpp-2.7.2-zeroc.patch
deleted file mode 100644
index fff5d321fe98..000000000000
--- a/dev-cpp/libmcpp/files/libmcpp-2.7.2-zeroc.patch
+++ /dev/null
@@ -1,75 +0,0 @@
-Description: Fixes by ZeroC, Inc.
-Author: ZeroC, Inc.
-Bug-Debian: http://bugs.debian.org/611749
-
---- mcpp-2.7.2.orig/src/main.c
-+++ mcpp-2.7.2/src/main.c
-@@ -326,6 +326,8 @@ static void init_main( void)
- = FALSE;
- option_flags.trig = TRIGRAPHS_INIT;
- option_flags.dig = DIGRAPHS_INIT;
-+ sh_file = NULL;
-+ sh_line = 0;
- }
-
- int mcpp_lib_main
---- mcpp-2.7.2.orig/src/support.c
-+++ mcpp-2.7.2/src/support.c
-@@ -188,7 +188,7 @@ static char * append_to_buffer(
- size_t length
- )
- {
-- if (mem_buf_p->bytes_avail < length) { /* Need to allocate more memory */
-+ if (mem_buf_p->bytes_avail < length + 1) { /* Need to allocate more memory */
- size_t size = MAX( BUF_INCR_SIZE, length);
-
- if (mem_buf_p->buffer == NULL) { /* 1st append */
-@@ -1722,6 +1722,8 @@ com_start:
- sp -= 2;
- while (*sp != '\n') /* Until end of line */
- mcpp_fputc( *sp++, OUT);
-+ mcpp_fputc( '\n', OUT);
-+ wrong_line = TRUE;
- }
- goto end_line;
- default: /* Not a comment */
---- mcpp-2.7.2.orig/src/internal.H
-+++ mcpp-2.7.2/src/internal.H
-@@ -390,6 +390,8 @@ extern char * const work_end; /* E
- extern char identifier[]; /* Lastly scanned name */
- extern IFINFO ifstack[]; /* Information of #if nesting */
- extern char work_buf[];
-+extern FILEINFO * sh_file;
-+extern int sh_line;
- /* Temporary buffer for directive line and macro expansion */
-
- /* main.c */
-@@ -557,6 +559,6 @@ extern void init_system( void);
- #endif
- #endif
-
--#if HOST_HAVE_STPCPY
-+#if HOST_HAVE_STPCPY && !defined(stpcpy)
- extern char * stpcpy( char * dest, const char * src);
- #endif
---- mcpp-2.7.2.orig/src/system.c
-+++ mcpp-2.7.2/src/system.c
-@@ -3858,6 +3858,9 @@ static int chk_dirp(
- }
- #endif
-
-+FILEINFO* sh_file;
-+int sh_line;
-+
- void sharp(
- FILEINFO * sharp_file,
- int flag /* Flag to append to the line for GCC */
-@@ -3868,8 +3871,6 @@ void sharp(
- * else (i.e. 'sharp_file' is NULL) 'infile'.
- */
- {
-- static FILEINFO * sh_file;
-- static int sh_line;
- FILEINFO * file;
- int line;
-