summaryrefslogtreecommitdiff
path: root/dev-cpp/highway/highway-1.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-10 14:18:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-10 14:18:01 +0100
commite9c5cd3a9230f2f3f5980a5ca0c4ec20c099c7ed (patch)
treed7c270e41be9693c41fdb4ce3833f7dd151d95b2 /dev-cpp/highway/highway-1.0.0.ebuild
parentc2968b21192246c8fa4e99d5a2944658096f868e (diff)
gentoo auto-resync : 10:08:2022 - 14:18:00
Diffstat (limited to 'dev-cpp/highway/highway-1.0.0.ebuild')
-rw-r--r--dev-cpp/highway/highway-1.0.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-cpp/highway/highway-1.0.0.ebuild b/dev-cpp/highway/highway-1.0.0.ebuild
new file mode 100644
index 000000000000..89b07a85a587
--- /dev/null
+++ b/dev-cpp/highway/highway-1.0.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CMAKE_ECLASS=cmake
+inherit cmake-multilib
+
+DESCRIPTION="Performance-portable, length-agnostic SIMD with runtime dispatch"
+HOMEPAGE="https://github.com/google/highway"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/google/highway.git"
+else
+ SRC_URI="https://github.com/google/highway/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+
+DEPEND="test? ( dev-cpp/gtest[${MULTILIB_USEDEP}] )"
+
+RESTRICT="!test? ( test )"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
+ -DHWY_WARNINGS_ARE_ERRORS=OFF
+ )
+
+ use test && mycmakeargs+=( "-DHWY_SYSTEM_GTEST=ON" )
+
+ cmake_src_configure
+}