summaryrefslogtreecommitdiff
path: root/dev-cpp/gtest/gtest-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-cpp/gtest/gtest-9999.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-cpp/gtest/gtest-9999.ebuild')
-rw-r--r--dev-cpp/gtest/gtest-9999.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/dev-cpp/gtest/gtest-9999.ebuild b/dev-cpp/gtest/gtest-9999.ebuild
index 753803041fce..40af1cfe82d5 100644
--- a/dev-cpp/gtest/gtest-9999.ebuild
+++ b/dev-cpp/gtest/gtest-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=7
# Python is required for tests and some build tasks.
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python3_{6,7,8,9} )
CMAKE_ECLASS=cmake
inherit cmake-multilib python-any-r1
@@ -31,11 +31,10 @@ SLOT="0"
IUSE="doc examples test"
RESTRICT="!test? ( test )"
-DEPEND="test? ( ${PYTHON_DEPS} )"
-RDEPEND="!dev-cpp/gmock"
+BDEPEND="test? ( ${PYTHON_DEPS} )"
PATCHES=(
- "${FILESDIR}"/${PN}-1.9.0_pre20190607-increase-clone-stack-size.patch
+ "${FILESDIR}"/${PN}-1.10.0_p20200702-increase-clone-stack-size.patch
)
pkg_setup() {