summaryrefslogtreecommitdiff
path: root/dev-cpp/gtest/gtest-1.7.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
commitf1af93971b7490792d8541bc790e0d8c6d787059 (patch)
treea38046712bbc3a3844d77452d16c84e716caa3d4 /dev-cpp/gtest/gtest-1.7.0-r1.ebuild
parentfc637fb28da700da71ec2064d65ca5a7a31b9c6c (diff)
gentoo resync : 06.08.2019
Diffstat (limited to 'dev-cpp/gtest/gtest-1.7.0-r1.ebuild')
-rw-r--r--dev-cpp/gtest/gtest-1.7.0-r1.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/dev-cpp/gtest/gtest-1.7.0-r1.ebuild b/dev-cpp/gtest/gtest-1.7.0-r1.ebuild
deleted file mode 100644
index 360809f62e74..000000000000
--- a/dev-cpp/gtest/gtest-1.7.0-r1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-AUTOTOOLS_AUTORECONF=1
-AUTOTOOLS_IN_SOURCE_BUILD=1
-# Python is required for tests and some build tasks.
-PYTHON_COMPAT=( python2_7 )
-
-inherit eutils python-any-r1 autotools-multilib
-
-DESCRIPTION="Google C++ Testing Framework"
-HOMEPAGE="https://github.com/google/googletest"
-SRC_URI="https://github.com/google/googletest/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="examples static-libs"
-
-DEPEND="${PYTHON_DEPS}"
-RDEPEND=""
-
-PATCHES=(
- "${FILESDIR}/configure-fix-pthread-linking.patch" #371647
-)
-
-src_prepare() {
- sed -i -e "s|/tmp|${T}|g" test/gtest-filepath_test.cc || die
- sed -i -r \
- -e '/^install-(data|exec)-local:/s|^.*$|&\ndisabled-&|' \
- Makefile.am || die
- autotools-multilib_src_prepare
-}
-
-multilib_src_install() {
- default
- multilib_is_native_abi && dobin scripts/gtest-config
-}
-
-multilib_src_install_all() {
- prune_libtool_files --all
- einstalldocs
-
- if use examples ; then
- insinto /usr/share/doc/${PF}/examples
- doins samples/*.{cc,h}
- fi
-}