summaryrefslogtreecommitdiff
path: root/dev-cpp/gflags/gflags-2.2.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-01 21:05:47 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-01 21:05:47 +0000
commit60f657b5e6155f26601c7def7baa11cee72246d0 (patch)
tree25aecda1c8de352c03f653934407abebf384a560 /dev-cpp/gflags/gflags-2.2.1-r1.ebuild
parente523ebcd50638ebe53f8f425d126bfa7385703b5 (diff)
gentoo auto-resync : 01:02:2023 - 21:05:47
Diffstat (limited to 'dev-cpp/gflags/gflags-2.2.1-r1.ebuild')
-rw-r--r--dev-cpp/gflags/gflags-2.2.1-r1.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-cpp/gflags/gflags-2.2.1-r1.ebuild b/dev-cpp/gflags/gflags-2.2.1-r1.ebuild
deleted file mode 100644
index 423e936e4bf2..000000000000
--- a/dev-cpp/gflags/gflags-2.2.1-r1.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake-multilib
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/gflags/gflags"
-else
- SRC_URI="https://github.com/gflags/gflags/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
-fi
-
-DESCRIPTION="Google's C++ argument parsing library"
-HOMEPAGE="https://gflags.github.io/gflags/"
-
-LICENSE="BSD"
-SLOT="0/2.2"
-IUSE="static-libs test"
-RESTRICT="!test? ( test )"
-
-# AUTHORS.txt only links the google group
-DOCS=( ChangeLog.txt README.md )
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DBUILD_STATIC_LIBS=$(usex static-libs)
- -DBUILD_TESTING=$(usex test)
- # avoid installing .cmake/packages, e.g.:
- # >>> /tmp/portage/dev-cpp/gflags-9999/homedir/.cmake/packages/gflags/a7fca4708532331c2d656af0fdc8b8b9
- -DREGISTER_INSTALL_PREFIX=OFF
- )
- cmake_src_configure
-}