summaryrefslogtreecommitdiff
path: root/dev-cpp/frugally-deep/frugally-deep-0.15.30.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-09 01:07:53 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-09 01:07:53 +0000
commit4464bf26d93bdcc80e0b1330fe9c9caef26b34fc (patch)
tree62f9e9438bf700cf277191db5d7c3a641bc972dc /dev-cpp/frugally-deep/frugally-deep-0.15.30.ebuild
parent8edd4a48a39640822abe6ddb7b2a1d5b2da4ea70 (diff)
gentoo auto-resync : 09:03:2024 - 01:07:53
Diffstat (limited to 'dev-cpp/frugally-deep/frugally-deep-0.15.30.ebuild')
-rw-r--r--dev-cpp/frugally-deep/frugally-deep-0.15.30.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-cpp/frugally-deep/frugally-deep-0.15.30.ebuild b/dev-cpp/frugally-deep/frugally-deep-0.15.30.ebuild
new file mode 100644
index 000000000000..10423b3cb2a8
--- /dev/null
+++ b/dev-cpp/frugally-deep/frugally-deep-0.15.30.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Header-only library for using Keras models in C++"
+HOMEPAGE="https://github.com/Dobiasd/frugally-deep"
+SRC_URI="https://github.com/Dobiasd/frugally-deep/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-cpp/functional-plus
+ dev-cpp/eigen
+ dev-cpp/nlohmann_json
+"
+
+RDEPEND="${DEPEND}"