summaryrefslogtreecommitdiff
path: root/dev-cpp/folly
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-14 05:44:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-14 05:44:50 +0100
commit1d18b53ed419c49eb3f71637ccd58a431c1368d4 (patch)
treeeb3671b1209855aa64534ee96262d06bcda99d74 /dev-cpp/folly
parentfdca6388cf31827202fae75cae067c695bd09339 (diff)
gentoo auto-resync : 14:04:2023 - 05:44:49
Diffstat (limited to 'dev-cpp/folly')
-rw-r--r--dev-cpp/folly/Manifest2
-rw-r--r--dev-cpp/folly/folly-2023.04.10.00.ebuild110
2 files changed, 112 insertions, 0 deletions
diff --git a/dev-cpp/folly/Manifest b/dev-cpp/folly/Manifest
index 8b95054192e7..972cd7ee370d 100644
--- a/dev-cpp/folly/Manifest
+++ b/dev-cpp/folly/Manifest
@@ -1,6 +1,8 @@
AUX folly-2022.07.04.00-musl-fix.patch 1150 BLAKE2B 6774badf3856fa94ae69dc4ca3fb3aca628dcf3b96fd7d141967815a9a07c07349f852a35275baba7b91d60e0c61dc3e1639cab4727666fa128d0334f36815a2 SHA512 15029e25b4da1f9cfe227978a54f63c198361df665b4657ef6a80ffdd3911c80be8e6c3799c8c16ff0fcca050932155628651a6e5ed566a41174dced9e51dc58
DIST folly-v2022.08.29.00.tar.gz 3696645 BLAKE2B c1ff618be8b6a73bf0a1249212cf904ac472711086e54da73dd631ecf002761e30496e8631d6591f51e279b736ae9b3fe50959de6b1f86f01f9d6bc08fe675fc SHA512 1437a1314e26624715a0bb781049e19300eb3a67648287b319c55ce0dfbc867a09bd9d2f0cece6fc75fc62b21899aa94b464ae49c12687be7c94fdf0c7b95790
DIST folly-v2023.02.06.00.tar.gz 3790845 BLAKE2B b1c0eed7a2dccba3ccb5e25aa24cc0a6d628fbc3134bf0ed82a1e0e614825a3ae620d79a54e2bea398274afcb662bdfca48d7193f69db35f624ed6a2fa9bae99 SHA512 b9cd8132a702e88e4c9fefcce190d9fd403253c9b71dc22316f237922d99f9cd980ab81d50ddb48ae0e614a493b3d61865b03eee46d59805f83fce528f831646
+DIST folly-v2023.04.10.00.tar.gz 3816300 BLAKE2B fe262148583321ee55da9305a9e060e48915598c08edbd0edb884529d0a9547783f2e1a45b0f39e461ea6b92e9c0b74fc7b071ec1ed044b810ac2065c93a5f10 SHA512 4f154127f24e2e57873ed8e135989c214ae3bbaf0302594b3e67de89e04bf4905f45471a488220ecade56b9ae2b928a779b66f7632210a02b1087a4c05141d5a
EBUILD folly-2022.08.29.00.ebuild 2474 BLAKE2B ba8b143ee679b37e2facd8ac30f6eee6ca8fd2606c5731757f2a2b5d6f6a9ce655d97f97317c907c5452e0e6494e81ee1dee376d97c708cc950b9e1e6090853d SHA512 81b7baddf458a0d394e158671f71f613fc7b760aea065b5ce7ab26856bdae9303462ac770b6dd067bf49f63fc776fdae4a66c9437cd9de009a2e716969e044f1
EBUILD folly-2023.02.06.00.ebuild 2691 BLAKE2B 87fa37f79761d5222734d38f2e3955b3d48200b8f197d6e655e1f59cd7d11b480a045f0bb09b25930d9cf210ef39ab8c6e8de3514e1dfd65b295e0c2f948cc31 SHA512 f7dfdee2935ac1c2b22300d7646e2c2d8ec595733c3e087d67b599a773d8fc90802ca977354da45271fd26a8a5ae0b1dd7598e9557dfb243dcd101441550f9c4
+EBUILD folly-2023.04.10.00.ebuild 2822 BLAKE2B fa3df4771db2609c819bc25f63999bd46162b65887aacb713ec4d009ba8b93c332fa1c5d0138e57d8a7bbee302c383fa2f0f32784a59afabdfc0660d7a2328ea SHA512 d82f58b20eecc0420fba647575d2822f0e13ec5b33cf8a72db5a459ad8e7131f4255136229331c21338015109eb99000d4711b6fc145b6309d16db719167ca65
MISC metadata.xml 319 BLAKE2B 0c8d18b906a50ee77fef7db1f99206b1c4d38dfa7913de363474609bcce38956be8d0958bc400c704ad743396db7230fb0098c83f1caa16ca998d6fd5576369c SHA512 8b077d5d5bf60f0ed5b36aef48188f431ca0675f80190beb407a58fa48fc6f8a48db161b8cde775ab6cfb54a01438fa5edddf0098e80a65b29a403a7f3a2c027
diff --git a/dev-cpp/folly/folly-2023.04.10.00.ebuild b/dev-cpp/folly/folly-2023.04.10.00.ebuild
new file mode 100644
index 000000000000..77a442688377
--- /dev/null
+++ b/dev-cpp/folly/folly-2023.04.10.00.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# These must be bumped together:
+# dev-cpp/edencommon
+# dev-cpp/folly
+# dev-util/watchman
+
+inherit cmake toolchain-funcs
+
+DESCRIPTION="An open-source C++ library developed and used at Facebook"
+HOMEPAGE="https://github.com/facebook/folly"
+SRC_URI="https://github.com/facebook/folly/releases/download/v${PV}/${PN}-v${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64"
+IUSE="llvm-libunwind test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="app-arch/bzip2
+ app-arch/lz4:=
+ app-arch/snappy:=
+ app-arch/xz-utils
+ app-arch/zstd:=
+ dev-cpp/gflags:=
+ dev-cpp/glog:=[gflags]
+ dev-libs/boost:=[context]
+ dev-libs/double-conversion:=
+ dev-libs/libaio
+ dev-libs/libevent:=
+ dev-libs/libfmt:=
+ dev-libs/libsodium:=
+ dev-libs/openssl:=
+ >=sys-libs/liburing-2.3:=
+ sys-libs/zlib
+ llvm-libunwind? ( sys-libs/llvm-libunwind:= )
+ !llvm-libunwind? ( sys-libs/libunwind:= )"
+# libiberty is linked statically
+DEPEND="${RDEPEND}
+ sys-libs/binutils-libs
+ test? ( dev-cpp/gtest )"
+BDEPEND="test? ( sys-devel/clang )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2022.07.04.00-musl-fix.patch
+)
+
+pkg_setup() {
+ [[ ${BUILD_TYPE} == binary ]] && return
+
+ if use test && ! tc-is-clang ; then
+ # Always build w/ Clang for now to avoid gcc ICE
+ # https://gcc.gnu.org/bugzilla/show_bug.cgi?id=106230
+ #if [[ $(gcc-major-version) -eq 12 ]] ; then
+ # return
+ #fi
+
+ ## Only older GCC 11 is broken
+ #if [[ $(gcc-major-version) -eq 11 && $(gcc-minor-version) -ge 3 && $(gcc-micro-version) -ge 1 ]] ; then
+ # return
+ #fi
+
+ ewarn "Forcing build with Clang due to GCC bug (because tests are enabled)"
+ #ewarn "(https://gcc.gnu.org/bugzilla/show_bug.cgi?id=104008)"
+
+ #export CC=${CHOST}-clang
+ #export CXX=${CHOST}-clang++
+ fi
+}
+
+src_unpack() {
+ # Workaround for bug #889420
+ mkdir -p "${S}" || die
+ cd "${S}" || die
+ default
+}
+
+src_configure() {
+ # TODO: liburing could in theory be optional but fails to link
+ local mycmakeargs=(
+ -DLIB_INSTALL_DIR="$(get_libdir)"
+
+ -DBUILD_TESTS=$(usex test)
+
+ # https://github.com/gentoo/gentoo/pull/29393
+ -DCMAKE_LIBRARY_ARCHITECTURE=$(usex amd64 x86_64 ${ARCH})
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ local myctestargs=(
+ # - timeseries_histogram_test.TimeseriesHistogram.Percentile|HHWheelTimerTest
+ # Long-standing known test failure
+ # TODO: report upstream
+ # - HHWheelTimerTest.HHWheelTimerTest.CancelTimeout
+ # Timeouts are fragile
+ # - concurrent_hash_map_test.*
+ # TODO: All SIGSEGV, report upstream!
+ # - ssl_errors_test.SSLErrorsTest.TestMessage
+ # Network...?
+ -E "(timeseries_histogram_test.TimeseriesHistogram.Percentile|HHWheelTimerTest.HHWheelTimerTest.CancelTimeout|concurrent_hash_map_test.*|ssl_errors_test.SSLErrorsTest.TestMessage)"
+ )
+
+ cmake_src_test
+}