summaryrefslogtreecommitdiff
path: root/dev-cpp/folly/folly-2023.05.22.00.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-25 10:31:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-25 10:31:10 +0000
commit2900e684ae4bdce1f20652587728095cd01a30a1 (patch)
treedb7b5054b7d0de362a2960a0a7268ffc37b8e1f9 /dev-cpp/folly/folly-2023.05.22.00.ebuild
parentff8c6e4babf1a2911b8d61b6bb7e80290355cb70 (diff)
gentoo auto-resync : 25:11:2023 - 10:31:10
Diffstat (limited to 'dev-cpp/folly/folly-2023.05.22.00.ebuild')
-rw-r--r--dev-cpp/folly/folly-2023.05.22.00.ebuild90
1 files changed, 0 insertions, 90 deletions
diff --git a/dev-cpp/folly/folly-2023.05.22.00.ebuild b/dev-cpp/folly/folly-2023.05.22.00.ebuild
deleted file mode 100644
index 11d6692f182c..000000000000
--- a/dev-cpp/folly/folly-2023.05.22.00.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# These must be bumped together:
-# dev-cpp/edencommon
-# dev-cpp/folly
-# dev-util/watchman
-
-inherit cmake
-
-DESCRIPTION="An open-source C++ library developed and used at Facebook"
-HOMEPAGE="https://github.com/facebook/folly"
-SRC_URI="https://github.com/facebook/folly/releases/download/v${PV}/${PN}-v${PV}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0/${PV}"
-KEYWORDS="amd64 ~ppc64"
-IUSE="llvm-libunwind test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- app-arch/bzip2
- app-arch/lz4:=
- app-arch/snappy:=
- app-arch/xz-utils
- app-arch/zstd:=
- dev-cpp/gflags:=
- dev-cpp/glog:=[gflags]
- dev-libs/boost:=[context]
- dev-libs/double-conversion:=
- dev-libs/libaio
- dev-libs/libevent:=
- dev-libs/libfmt:=
- dev-libs/libsodium:=
- dev-libs/openssl:=
- >=sys-libs/liburing-2.3:=
- sys-libs/zlib
- llvm-libunwind? ( sys-libs/llvm-libunwind:= )
- !llvm-libunwind? ( sys-libs/libunwind:= )
-"
-# libiberty is linked statically
-DEPEND="
- ${RDEPEND}
- sys-libs/binutils-libs
- test? ( dev-cpp/gtest )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2023.05.22.00-musl-fix.patch
-)
-
-src_unpack() {
- # Workaround for bug #889420
- mkdir -p "${S}" || die
- cd "${S}" || die
- default
-}
-
-src_configure() {
- # TODO: liburing could in theory be optional but fails to link
- local mycmakeargs=(
- -DLIB_INSTALL_DIR="$(get_libdir)"
-
- -DBUILD_TESTS=$(usex test)
-
- # https://github.com/gentoo/gentoo/pull/29393
- -DCMAKE_LIBRARY_ARCHITECTURE=$(usex amd64 x86_64 ${ARCH})
- )
-
- cmake_src_configure
-}
-
-src_test() {
- local myctestargs=(
- # - timeseries_histogram_test.TimeseriesHistogram.Percentile|HHWheelTimerTest
- # Long-standing known test failure
- # TODO: report upstream
- # - HHWheelTimerTest.HHWheelTimerTest.CancelTimeout
- # Timeouts are fragile
- # - concurrent_hash_map_test.*
- # TODO: All SIGSEGV, report upstream!
- # - ssl_errors_test.SSLErrorsTest.TestMessage
- # Network...?
- -E "(timeseries_histogram_test.TimeseriesHistogram.Percentile|HHWheelTimerTest.HHWheelTimerTest.CancelTimeout|concurrent_hash_map_test.*|ssl_errors_test.SSLErrorsTest.TestMessage)"
- )
-
- cmake_src_test
-}