summaryrefslogtreecommitdiff
path: root/dev-cpp/expected-lite/expected-lite-0.6.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-10 15:51:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-10 15:51:39 +0100
commit42e82780761e75f17a5cc96626558a297782f385 (patch)
tree45425190df4e3cbf429fd2b0834f320d51fd6579 /dev-cpp/expected-lite/expected-lite-0.6.3.ebuild
parent3d00647fec2600e217d690a64ba45a41f1a2fa0c (diff)
gentoo auto-resync : 10:06:2023 - 15:51:39
Diffstat (limited to 'dev-cpp/expected-lite/expected-lite-0.6.3.ebuild')
-rw-r--r--dev-cpp/expected-lite/expected-lite-0.6.3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-cpp/expected-lite/expected-lite-0.6.3.ebuild b/dev-cpp/expected-lite/expected-lite-0.6.3.ebuild
new file mode 100644
index 000000000000..6ee9aecf0708
--- /dev/null
+++ b/dev-cpp/expected-lite/expected-lite-0.6.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Expected objects in C++11 and later in a single-file header-only library"
+HOMEPAGE="https://github.com/martinmoene/expected-lite"
+
+SRC_URI="https://github.com/martinmoene/expected-lite/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DEXPECTED_LITE_OPT_BUILD_TESTS=$(usex test)
+ )
+
+ cmake_src_configure
+}